Uploaded image for project: 'Commons Math'
  1. Commons Math
  2. MATH-707

Naming confusion

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Labels:

      Description

      This issue was raised in this thread on the "dev" ML.
      It proposes to consistently name classes/interfaces that refer to number types (e.g. "Real", "Complex", ...) and structure (e.g. "Scalar", "Vectorial", ...), with "Real" and "Scalar" components in names being assumed (thus, not to be included in the name).

      For example, for the "Univariate..." interfaces (in package "analysis"), the proposal is to operate the following renaming:

      • UnivariateRealFunction -> UnivariateFunction
      • UnivariateRealVectorialFunction -> UnivariateVectorFunction
      • UnivariateMatrixFunction -> UnivariateMatrixFunction

      Similar changes are in order in the package "optimization" (where "Real" is sometimes included in the name and sometimes not, or used instead of "Scalar").

        Attachments

          Activity

            People

            • Assignee:
              erans Gilles Sadowski
              Reporter:
              erans Gilles Sadowski
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: