Uploaded image for project: 'Commons Math'
  1. Commons Math
  2. MATH-455

[PATCH] Allow Clirr minSeverity to be overridden on the command-line

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 2.2, 3.0
    • None

    Description

      Unfortunately, Maven command-line parameters cannot be used to override configuration options (only to provide defaults), so with the current Math POMs it's not possible to change the minimum Clirr severity without editting pom.xml

      The patch defines a property with the name minSeverity which defines the default value, and uses it in the configuration section.

      This allows the user to override minSeverity on the command-line, and will continue to work even if the <minSeverity> configuration is ever dropped.

      Attachments

        1. MATH-455.patch
          0.8 kB
          Sebb

        Activity

          People

            Unassigned Unassigned
            sebb Sebb
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: