Uploaded image for project: 'Maven Assembly Plugin'
  1. Maven Assembly Plugin
  2. MASSEMBLY-46

artifact classifier not used in outputFileNameMapping

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Linux

      Description

      The classifier field of an artifact cannot be specified in the outputFileNameMapping.
      This means that attached Artifacts with the same type cannot be distinguished.
      I have a native code libraries attached to a java jar. Next, I have documentation etc attached to the artifact. All files have type .tgz.
      When I specify a depencySet I end up with only one file, instead of several. This is caused by the fact that classifier is removed from the name of the the original input artifact file.

      The workaround is to rename attached artifacts to a different type (rename .tgz to .tar.gz...).

        Issue Links

          Activity

          aramirez Allan Ramirez added a comment -

          Fixed in svn.


            People

            • Assignee:
              aramirez Allan Ramirez
              Reporter:
              mvdp M. van der Plas
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development