Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-891

Streaming tests fail with NPE in MiniDFSCluster

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: contrib/streaming, test
    • Labels:
      None

      Description

      Streaming testcases' usage of MiniDFSCluster.startDatanodes causes NPE in GenericOptionsParser:

      java.lang.NullPointerException
      	at org.apache.commons.cli.GnuParser.flatten(GnuParser.java:110)
      	at org.apache.commons.cli.Parser.parse(Parser.java:143)
      	at org.apache.hadoop.util.GenericOptionsParser.parseGeneralOptions(GenericOptionsParser.java:374)
      	at org.apache.hadoop.util.GenericOptionsParser.<init>(GenericOptionsParser.java:153)
      	at org.apache.hadoop.util.GenericOptionsParser.<init>(GenericOptionsParser.java:138)
      	at org.apache.hadoop.hdfs.server.datanode.DataNode.instantiateDataNode(DataNode.java:1314)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.startDataNodes(MiniDFSCluster.java:414)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:278)
      	at org.apache.hadoop.hdfs.MiniDFSCluster.<init>(MiniDFSCluster.java:119)
      	at org.apache.hadoop.streaming.TestDumpTypedBytes.testDumping(TestDumpTypedBytes.java:40)
      

        Issue Links

          Activity

          Vinod Kumar Vavilapalli added a comment -

          Duplicate of MAPREDUCE-699


            People

            • Assignee:
              Unassigned
              Reporter:
              Arun C Murthy
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development