Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-708

node health check script does not refresh the "reason for blacklisting"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: tasktracker
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      After MAPREDUCE-211, the node health check script does not refresh the "reason for blacklisting".
      The steps to reproduce the issue are:

      • Blacklist a TT with an error message 'x'
      • Change the health check script to return an error message 'y'
      • The "reason for blacklisting" still shows 'x'

      The impact of this issue is that the feature fails to trap transient errors.

      1. MAPREDUCE-708-1.patch
        3 kB
        Sreekanth Ramakrishnan
      2. MAPREDUCE-708-ydist.patch
        1 kB
        Sreekanth Ramakrishnan

        Activity

        Sreekanth Ramakrishnan added a comment -

        Attaching patch fixing the issue pointed out by Ramya.

        Patch removes the condition which checks if the TT was already blacklisted for the same reason and ignore further processing.
        Added test case to verify the error messages were changed even if the reason is same.

        Hemanth Yamijala added a comment -

        Changes look good. +1. Can you please run ant test-patch and relevant tests.

        Sreekanth Ramakrishnan added a comment -

        output from ant test-patch:

             [exec]
             [exec] +1 overall.
             [exec]
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec]
             [exec]     +1 tests included.  The patch appears to include 3 new or modified tests.
             [exec]
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec]
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec]
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec]
             [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
             [exec]
             [exec]
             [exec]
        

        Running tests.

        Sreekanth Ramakrishnan added a comment -

        All test passed locally, except the restart test cases which are being worked upon.

        Sreekanth Ramakrishnan added a comment -

        Y! distribution patch.

        Hemanth Yamijala added a comment -

        I just committed this. Thanks, Sreekanth !

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #15 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk/15/)
        . Fixes a bug to allow updating the reason for blacklisting a node on the JobTracker UI. Contributed by Sreekanth Ramakrishnan.


          People

          • Assignee:
            Sreekanth Ramakrishnan
            Reporter:
            Ramya Sunil
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development