Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 2.7.4, 3.0.0-alpha1
    • Component/s: mrv2
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      1 tests failed.
      REGRESSION: org.apache.hadoop.mapreduce.v2.app.TestRecovery.testSpeculative

      Error Message:
      null

      Stack Trace:
      java.lang.NullPointerException: null
      at org.apache.hadoop.mapreduce.v2.app.TestRecovery.testSpeculative(TestRecovery.java:1201)

      1. mapreduce6768.001.patch
        1 kB
        Haibo Chen
      2. mapreduce6768.002.patch
        2 kB
        Haibo Chen

        Activity

        haibochen Haibo Chen added a comment -
           
        ContainerId t1a2contId = task1Attempt2.getAssignedContainerID();
        LOG.info(t1a2contId.toString());
        

        TaskAttempt2 may not have been assigned a container, this is why there is a NPE. Uploading a trivial patch to fix this.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 21s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 59s trunk passed
        +1 compile 0m 23s trunk passed
        +1 checkstyle 0m 17s trunk passed
        +1 mvnsite 0m 30s trunk passed
        +1 mvneclipse 0m 16s trunk passed
        +1 findbugs 0m 37s trunk passed
        +1 javadoc 0m 16s trunk passed
        +1 mvninstall 0m 24s the patch passed
        +1 compile 0m 23s the patch passed
        +1 javac 0m 23s the patch passed
        -1 checkstyle 0m 15s hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app: The patch generated 1 new + 118 unchanged - 1 fixed = 119 total (was 119)
        +1 mvnsite 0m 27s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 45s the patch passed
        +1 javadoc 0m 13s the patch passed
        +1 unit 9m 4s hadoop-mapreduce-client-app in the patch passed.
        +1 asflicense 0m 15s The patch does not generate ASF License warnings.
        23m 13s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12825581/mapreduce6768.001.patch
        JIRA Issue MAPREDUCE-6768
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 51ccb7d6be4d 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 81485db
        Default Java 1.8.0_101
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6698/artifact/patchprocess/diff-checkstyle-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-app.txt
        Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6698/testReport/
        modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app U: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app
        Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6698/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        jlowe Jason Lowe added a comment -

        Thanks for the patch!

        I suspect this patch is going to be appropriate for more than just trunk, so as such it'd be good to avoid the lambda use.

        I think only a 800 msec wait is going to be too short if the test runs on a slow VM or some other hiccup occurs.

        Nit: Any reason to wait 100mec instead of 10 per iteration? Yes, I'm overly sensitive to sleeps lately with all the slow YARN tests.

        haibochen Haibo Chen added a comment -

        Thanks for the review Jason! I guess I must be following some bad practice I have seen in the code base. In the new patch, I have increased the overall timeout to 10s, and lowered the check interval to 10 milliseconds. Also, removed the use of lambda.

        jlowe Jason Lowe added a comment -

        I guess I must be following some bad practice I have seen in the code base.

        It's not a terrible practice, just that I've been sensitive to unnecessarily long sleeps in unit tests lately. See the discussion at YARN-5393 for details.

        +1 pending Jenkins. The patch still can't be used as-is on other branches since JDK7 will want task1Attempt2 to be final for use in the inner class, but that's something I can easily fix during the commit.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 16m 23s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 48s trunk passed
        +1 compile 0m 24s trunk passed
        +1 checkstyle 0m 17s trunk passed
        +1 mvnsite 0m 30s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 0m 34s trunk passed
        +1 javadoc 0m 16s trunk passed
        +1 mvninstall 0m 21s the patch passed
        +1 compile 0m 20s the patch passed
        +1 javac 0m 20s the patch passed
        -1 checkstyle 0m 14s hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app: The patch generated 1 new + 118 unchanged - 1 fixed = 119 total (was 119)
        +1 mvnsite 0m 26s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 0m 40s the patch passed
        +1 javadoc 0m 13s the patch passed
        +1 unit 8m 49s hadoop-mapreduce-client-app in the patch passed.
        +1 asflicense 0m 16s The patch does not generate ASF License warnings.
        37m 39s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12825692/mapreduce6768.002.patch
        JIRA Issue MAPREDUCE-6768
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux cacaee0233c1 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / cde3a00
        Default Java 1.8.0_101
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6699/artifact/patchprocess/diff-checkstyle-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-app.txt
        Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6699/testReport/
        modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app U: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app
        Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6699/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        jlowe Jason Lowe added a comment -

        Thanks, Haibo Chen! I committed this to trunk, branch-2, branch-2.8, and branch-2.7.

        haibochen Haibo Chen added a comment -

        Thanks Jason Lowe for the kind review!

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10367 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10367/)
        MAPREDUCE-6768. TestRecovery.testSpeculative failed with NPE. (jlowe: rev 69f7277625b86a30a5964285d05dac4ba982e795)

        • (edit) hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/test/java/org/apache/hadoop/mapreduce/v2/app/TestRecovery.java

          People

          • Assignee:
            haibochen Haibo Chen
            Reporter:
            haibochen Haibo Chen
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development