Uploaded image for project: 'Hadoop Map/Reduce'
  1. Hadoop Map/Reduce
  2. MAPREDUCE-6677

LocalContainerAllocator doesn't specify resource of the containers allocated.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-alpha1
    • Component/s: mr-am
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed
    1. mapreduce6677.001.patch
      7 kB
      Haibo Chen
    2. mapreduce6677.002.patch
      8 kB
      Haibo Chen
    3. mapreduce6677.003.patch
      8 kB
      Haibo Chen

      Issue Links

        Activity

        haibochen Haibo Chen added a comment -

        The resource of an allocated container is expected in MAPREDUCE-6647 to calculate job resource counters.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 13s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
        0 mvndep 0m 10s Maven dependency ordering for branch
        +1 mvninstall 6m 47s trunk passed
        +1 compile 1m 29s trunk passed with JDK v1.8.0_77
        +1 compile 1m 44s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 23s trunk passed
        +1 mvnsite 1m 3s trunk passed
        +1 mvneclipse 0m 26s trunk passed
        +1 findbugs 1m 9s trunk passed
        +1 javadoc 0m 27s trunk passed with JDK v1.8.0_77
        +1 javadoc 0m 31s trunk passed with JDK v1.7.0_95
        0 mvndep 0m 9s Maven dependency ordering for patch
        +1 mvninstall 0m 45s the patch passed
        +1 compile 1m 26s the patch passed with JDK v1.8.0_77
        -1 javac 2m 20s hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.8.0_77 with JDK v1.8.0_77 generated 1 new + 355 unchanged - 7 fixed = 356 total (was 362)
        +1 javac 1m 27s the patch passed
        +1 compile 1m 38s the patch passed with JDK v1.7.0_95
        -1 javac 4m 0s hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.7.0_95 with JDK v1.7.0_95 generated 1 new + 360 unchanged - 7 fixed = 361 total (was 367)
        +1 javac 1m 38s the patch passed
        +1 checkstyle 0m 22s the patch passed
        +1 mvnsite 0m 50s the patch passed
        +1 mvneclipse 0m 22s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 28s the patch passed
        +1 javadoc 0m 22s the patch passed with JDK v1.8.0_77
        +1 javadoc 0m 27s the patch passed with JDK v1.7.0_95
        +1 unit 9m 5s hadoop-mapreduce-client-app in the patch passed with JDK v1.8.0_77.
        -1 unit 124m 35s hadoop-mapreduce-client-jobclient in the patch failed with JDK v1.8.0_77.
        +1 unit 9m 48s hadoop-mapreduce-client-app in the patch passed with JDK v1.7.0_95.
        -1 unit 114m 47s hadoop-mapreduce-client-jobclient in the patch failed with JDK v1.7.0_95.
        +1 asflicense 0m 32s Patch does not generate ASF License warnings.
        282m 15s



        Reason Tests
        JDK v1.8.0_77 Timed out junit tests org.apache.hadoop.mapred.TestMRIntermediateDataEncryption
          org.apache.hadoop.mapreduce.lib.jobcontrol.TestMapReduceJobControl
        JDK v1.7.0_95 Timed out junit tests org.apache.hadoop.mapred.TestMRIntermediateDataEncryption



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12799039/mapreduce6677.001.patch
        JIRA Issue MAPREDUCE-6677
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux a95375bb1569 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 69f3d42
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        javac hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.8.0_77: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6437/artifact/patchprocess/diff-compile-javac-hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.8.0_77.txt
        javac hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.7.0_95: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6437/artifact/patchprocess/diff-compile-javac-hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.7.0_95.txt
        unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6437/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_77.txt
        unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6437/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.7.0_95.txt
        unit test logs https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6437/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_77.txt https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6437/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.7.0_95.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6437/testReport/
        modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient U: hadoop-mapreduce-project/hadoop-mapreduce-client
        Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6437/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        haibochen Haibo Chen added a comment -

        The test failures are caused by time out, unrelated the changes here

        haibochen Haibo Chen added a comment -

        updated patch for the javadoc issue.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 18s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
        0 mvndep 0m 10s Maven dependency ordering for branch
        +1 mvninstall 6m 35s trunk passed
        +1 compile 1m 24s trunk passed with JDK v1.8.0_77
        +1 compile 1m 38s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 23s trunk passed
        +1 mvnsite 0m 54s trunk passed
        +1 mvneclipse 0m 28s trunk passed
        +1 findbugs 1m 8s trunk passed
        +1 javadoc 0m 26s trunk passed with JDK v1.8.0_77
        +1 javadoc 0m 31s trunk passed with JDK v1.7.0_95
        0 mvndep 0m 10s Maven dependency ordering for patch
        +1 mvninstall 0m 44s the patch passed
        +1 compile 1m 22s the patch passed with JDK v1.8.0_77
        -1 javac 2m 16s hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.8.0_77 with JDK v1.8.0_77 generated 1 new + 355 unchanged - 7 fixed = 356 total (was 362)
        +1 javac 1m 22s the patch passed
        +1 compile 1m 36s the patch passed with JDK v1.7.0_95
        -1 javac 3m 52s hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.7.0_95 with JDK v1.7.0_95 generated 1 new + 360 unchanged - 7 fixed = 361 total (was 367)
        +1 javac 1m 36s the patch passed
        +1 checkstyle 0m 21s the patch passed
        +1 mvnsite 0m 49s the patch passed
        +1 mvneclipse 0m 23s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 28s the patch passed
        +1 javadoc 0m 21s the patch passed with JDK v1.8.0_77
        +1 javadoc 0m 27s the patch passed with JDK v1.7.0_95
        +1 unit 8m 57s hadoop-mapreduce-client-app in the patch passed with JDK v1.8.0_77.
        -1 unit 102m 14s hadoop-mapreduce-client-jobclient in the patch failed with JDK v1.8.0_77.
        +1 unit 9m 43s hadoop-mapreduce-client-app in the patch passed with JDK v1.7.0_95.
        -1 unit 106m 50s hadoop-mapreduce-client-jobclient in the patch failed with JDK v1.7.0_95.
        +1 asflicense 0m 31s Patch does not generate ASF License warnings.
        251m 7s



        Reason Tests
        JDK v1.8.0_77 Failed junit tests hadoop.mapred.TestMRCJCFileOutputCommitter
        JDK v1.7.0_95 Failed junit tests hadoop.mapred.TestMRCJCFileOutputCommitter



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12799111/mapreduce6677.002.patch
        JIRA Issue MAPREDUCE-6677
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 89de3b802c64 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / cab9cba
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        javac hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.8.0_77: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6438/artifact/patchprocess/diff-compile-javac-hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.8.0_77.txt
        javac hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.7.0_95: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6438/artifact/patchprocess/diff-compile-javac-hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.7.0_95.txt
        unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6438/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_77.txt
        unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6438/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.7.0_95.txt
        unit test logs https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6438/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_77.txt https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6438/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.7.0_95.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6438/testReport/
        modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient U: hadoop-mapreduce-project/hadoop-mapreduce-client
        Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6438/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        haibochen Haibo Chen added a comment -

        Updated patch according to the newly-generated javadoc warning. The unit test is again unrelated.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 16s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 2 new or modified test files.
        0 mvndep 0m 11s Maven dependency ordering for branch
        +1 mvninstall 7m 56s trunk passed
        +1 compile 2m 15s trunk passed with JDK v1.8.0_77
        +1 compile 2m 5s trunk passed with JDK v1.7.0_95
        +1 checkstyle 0m 24s trunk passed
        +1 mvnsite 1m 1s trunk passed
        +1 mvneclipse 0m 29s trunk passed
        +1 findbugs 1m 20s trunk passed
        +1 javadoc 0m 36s trunk passed with JDK v1.8.0_77
        +1 javadoc 0m 34s trunk passed with JDK v1.7.0_95
        0 mvndep 0m 10s Maven dependency ordering for patch
        +1 mvninstall 0m 53s the patch passed
        +1 compile 2m 12s the patch passed with JDK v1.8.0_77
        +1 javac 3m 15s hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.8.0_77 with JDK v1.8.0_77 generated 0 new + 356 unchanged - 6 fixed = 356 total (was 362)
        +1 javac 2m 12s hadoop-mapreduce-client in the patch passed with JDK v1.8.0_77.
        +1 compile 1m 59s the patch passed with JDK v1.7.0_95
        +1 javac 5m 14s hadoop-mapreduce-project_hadoop-mapreduce-client-jdk1.7.0_95 with JDK v1.7.0_95 generated 0 new + 361 unchanged - 6 fixed = 361 total (was 367)
        +1 javac 1m 59s hadoop-mapreduce-client in the patch passed with JDK v1.7.0_95.
        +1 checkstyle 0m 24s the patch passed
        +1 mvnsite 0m 56s the patch passed
        +1 mvneclipse 0m 24s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 1m 41s the patch passed
        +1 javadoc 0m 32s the patch passed with JDK v1.8.0_77
        +1 javadoc 0m 30s the patch passed with JDK v1.7.0_95
        +1 unit 10m 45s hadoop-mapreduce-client-app in the patch passed with JDK v1.8.0_77.
        -1 unit 130m 3s hadoop-mapreduce-client-jobclient in the patch failed with JDK v1.8.0_77.
        +1 unit 10m 23s hadoop-mapreduce-client-app in the patch passed with JDK v1.7.0_95.
        +1 unit 115m 49s hadoop-mapreduce-client-jobclient in the patch passed with JDK v1.7.0_95.
        +1 asflicense 0m 28s Patch does not generate ASF License warnings.
        295m 33s



        Reason Tests
        JDK v1.8.0_77 Timed out junit tests org.apache.hadoop.mapreduce.lib.jobcontrol.TestMapReduceJobControl



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:fbe3e86
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12799296/mapreduce6677.003.patch
        JIRA Issue MAPREDUCE-6677
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux ba32450f2b5a 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / d8b729e
        Default Java 1.7.0_95
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_77 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_95
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6445/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_77.txt
        unit test logs https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6445/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_77.txt
        JDK v1.7.0_95 Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6445/testReport/
        modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient U: hadoop-mapreduce-project/hadoop-mapreduce-client
        Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6445/console
        Powered by Apache Yetus 0.2.0 http://yetus.apache.org

        This message was automatically generated.

        haibochen Haibo Chen added a comment -

        Timeout again.

        templedf Daniel Templeton added a comment -

        Thanks for the patches, Haibo Chen. Looks good in general. Why the TestMRJobs changes?

        haibochen Haibo Chen added a comment -

        TestUberAM is reusing TestMRJobs. Under uber mode, there is no counter events for JobCounter.SLOTS_MILLIS_MAPS and JobCounter.SLOTS_MILLIS_REDUCES because of the change made in MAPREDUCE-6647. So the assumption that there is always JobCounter.SLOTS* counter events to verify is no longer valid. Plus, they are deprecated.

        rkanter Robert Kanter added a comment -

        +1

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #9719 (See https://builds.apache.org/job/Hadoop-trunk-Commit/9719/)
        MAPREDUCE-6677. LocalContainerAllocator doesn't specify resource of the (rkanter: rev ecce3b7d53ab624c9931273716326c76641ea11d)

        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/local/LocalContainerAllocator.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/test/java/org/apache/hadoop/mapreduce/v2/app/local/TestLocalContainerAllocator.java
        rkanter Robert Kanter added a comment -

        Thanks Haibo. Committed to trunk and branch-2!


          People

          • Assignee:
            haibochen Haibo Chen
            Reporter:
            haibochen Haibo Chen
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development