Uploaded image for project: 'Hadoop Map/Reduce'
  1. Hadoop Map/Reduce
  2. MAPREDUCE-5764

Potential NullPointerException in YARNRunner.killJob(JobID arg0)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.3.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I found YARNRunner.killJob(JobID arg0) can throw NullPointerException if job status is null.

      clientCache.getClient(arg0).getJobStatus(arg0); can be null.

      This can happen when there is history write is failed because of hdfs errors or staging directory is different from history server..

      We need to have null check otherwise killJob() is prone to throw NPE which cause joblient to exit.

      @Override
        public void killJob(JobID arg0) throws IOException, InterruptedException {
          /* check if the status is not running, if not send kill to RM */
          JobStatus status = clientCache.getClient(arg0).getJobStatus(arg0);
          if (status.getState() != JobStatus.State.RUNNING) {
            try {
              resMgrDelegate.killApplication(TypeConverter.toYarn(arg0).getAppId());
            } catch (YarnException e) {
              throw new IOException(e);
            }
            return;
          }
      .......
      ......
      .......
        }
      

        Issue Links

          Activity

          rohithsharma Rohith Sharma K S added a comment -

          Yes Jason Lowe, it is duplicate. I shall take care before raising an issue avoding Jira Id waste

          jlowe Jason Lowe added a comment -

          This is a duplicate of MAPREDUCE-5542.


            People

            • Assignee:
              rohithsharma Rohith Sharma K S
              Reporter:
              rohithsharma Rohith Sharma K S
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development