Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-5650

Job fails when hprof mapreduce.task.profile.map/reduce.params is specified

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.3.0
    • Component/s: mrv2
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      When one uses dedicated hprof mapreduce.task.profile.map.params or mapreduce.task.profile.reduce.params, the profiled tasks will fail to launch because hprof parameters are supplied to the child jvm twice.

      1. MAPREDUCE-5650.v01.patch
        11 kB
        Gera Shegalov
      2. MAPREDUCE-5650.v02.patch
        11 kB
        Gera Shegalov
      3. MAPREDUCE-5650.v03.patch
        12 kB
        Gera Shegalov
      4. MAPREDUCE-5650.v04.patch
        12 kB
        Gera Shegalov

        Activity

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12615545/MAPREDUCE-5650.v01.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        -1 javac. The applied patch generated 1545 javac compiler warnings (more than the trunk's current 1544 warnings).

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapreduce.v2.app.TestRMContainerAllocator
        org.apache.hadoop.mapred.TestSequenceFileInputFormat
        org.apache.hadoop.mapred.TestJobCleanup

        The following test timeouts occurred in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapred.TestMultiFileInputFormat

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4228//testReport/
        Javac warnings: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4228//artifact/trunk/patchprocess/diffJavacWarnings.txt
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4228//console

        This message is automatically generated.

        Gera Shegalov added a comment -

        fixing javac deprecated warning

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12615647/MAPREDUCE-5650.v02.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapreduce.v2.app.TestRMContainerAllocator
        org.apache.hadoop.mapred.TestJobCleanup

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4230//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4230//console

        This message is automatically generated.

        Sandy Ryza added a comment -

        If I understand correctly, the issue is that the default (mapreduce.task.profile.params) params will be supplied even when more specific params are specified. Was the behavior different in MR1? Want to make sure this is not an incompatible change.

        Gera Shegalov added a comment -

        Sandy Ryza thanks for taking a look at the patch. Your understanding is correct. In MRv1 (branch-1), there are no task-type-specific profile params. The change is compatible. If the task-type-oblivious mapreduce.task.profile.params is specified then this value is used in the absence of a more specific key.

        Sandy Ryza added a comment -

        In that case I agree with you that this is a bug. MapReduce properties that have specific versions map/reduce versions (e.g mapreduce.map.java.opts) should ignore the generic version (e.g. mapred.child.java.opts) when the specific versions are specified. I'd like to get some other opinions on whether this is compatible before committing it though.

        Sandy Ryza added a comment -

        For reference, here is the JIRA where these options were added: MAPREDUCE-3426. It seems unrelated to them.

        Tom White added a comment -

        I can't see how mapreduce.task.profile.map/reduce.params could ever work since mapreduce.task.profile.params is always passed as a JVM parameter to the task JVM regardless of whether the more specific parameters are set. So I agree it's a bug, and the fix looks good.

        Tom White added a comment -

        Actually, I noticed a problem with the patch - it doesn't do interpolation of the profile filename (i.e. %s is replaced by the actual filename). Interpolation should be carried out for all three properties.

        Also, I noticed these properties are not in mapred-default.xml, so they should be added there.

        Gera Shegalov added a comment -

        Tom White, thanks for reviewing the patch. I added the profile.params properties to mapred-default, and fixed my traditional code style mistakes regarding whitespace on the second line.

        If I understand your interpolation comment correctly, the previous v02 version of the patch is already taking care of it. The string relevant for the current task attempt is first stored into profileParams and then we call.

                vargs.add(String.format(profileParams,
                    getTaskLogFile(TaskLog.LogName.PROFILE)));
        

        It's covered by the unit test in the patch. Please elaborate in more detail if I am missing something.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12619925/MAPREDUCE-5650.v03.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapreduce.security.TestJHSSecurity
        org.apache.hadoop.conf.TestJobConf

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4278//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4278//console

        This message is automatically generated.

        Tom White added a comment -

        Gera - sorry I somehow missed the interpolation part of your previous patch. +1 for the latest patch.

        Gera Shegalov added a comment -

        TestJobConf#testProfileParamsDefaults does not allow a default value for profile.params in mapred-default.xml. Removing it.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12623576/MAPREDUCE-5650.v04.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapreduce.v2.app.TestRMContainerAllocator

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4325//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4325//console

        This message is automatically generated.

        Gera Shegalov added a comment -

        Test failure TestRMContainerAllocator#testCompletedTasksRecalculateSchedule is reported MAPREDUCE-5726

        Sandy Ryza added a comment -

        I just committed this to trunk, branch-2, and branch-2.3. Thanks Gera!

        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-trunk-Commit #5017 (See https://builds.apache.org/job/Hadoop-trunk-Commit/5017/)
        MAPREDUCE-5650. Job fails when hprof mapreduce.task.profile.map/reduce.params is specified (Gera Shegalov via Sandy Ryza) (sandy: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1559201)

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/MapReduceChildJVM.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/resources/mapred-default.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobsWithProfiler.java
        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #456 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/456/)
        MAPREDUCE-5650. Job fails when hprof mapreduce.task.profile.map/reduce.params is specified (Gera Shegalov via Sandy Ryza) (sandy: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1559201)

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/MapReduceChildJVM.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/resources/mapred-default.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobsWithProfiler.java
        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #1648 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1648/)
        MAPREDUCE-5650. Job fails when hprof mapreduce.task.profile.map/reduce.params is specified (Gera Shegalov via Sandy Ryza) (sandy: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1559201)

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/MapReduceChildJVM.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/resources/mapred-default.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobsWithProfiler.java
        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #1673 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1673/)
        MAPREDUCE-5650. Job fails when hprof mapreduce.task.profile.map/reduce.params is specified (Gera Shegalov via Sandy Ryza) (sandy: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1559201)

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/MapReduceChildJVM.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/resources/mapred-default.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobsWithProfiler.java

          People

          • Assignee:
            Gera Shegalov
            Reporter:
            Gera Shegalov
          • Votes:
            0 Vote for this issue
            Watchers:
            9 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development