Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.0.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      The current implementation of sort in MapReduce is cooperated by Map side sort and Reduce side merge. MAPREDUCE-2454 provided pluggable sort at the Map side currently and pluggable shuffle at Reduce side, while no pluggable merger provided.

      Considering a general need of hash grouping and join, we may need to replace both the Map Sort and Reduce merge with a more light weight hash grouping alorithm. A general pluggable merge would help support this need.

        Issue Links

          Activity

          Alejandro Abdelnur added a comment -

          Jerry, unless I'm missing something from your description, this is a duplicate of MAPREDUCE-4808. Would you please check if that is the case and close this this one as dup of MAPREDUCE-4808 is so?. Thx

          Arun C Murthy added a comment -

          Duplicate of MAPREDUCE-4808

          Jerry Chen added a comment -

          Yes, it should be a duplication of MAPREDUCE-4808. While MAPREDUCE-4808 was originally as subtask of MAPREDCUE-2454. But MAPREDUCE-2454 was resolved without MAPREDUCE-4808. So I mistakenly think that the future was gone.


            People

            • Assignee:
              Unassigned
              Reporter:
              Jerry Chen
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 504h
                504h
                Remaining:
                Remaining Estimate - 504h
                504h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development