Uploaded image for project: 'Hadoop Map/Reduce'
  1. Hadoop Map/Reduce
  2. MAPREDUCE-4758

jobhistory web ui not showing correct # failed reducers

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.23.4
    • Fix Version/s: None
    • Component/s: jobhistoryserver, webapps
    • Labels:
      None
    • Target Version/s:

      Description

      we had a job fail due to a reducer failing 4 times. Unfortunately the job history UI didn't show this particular failed reducer which lead to confusion as to why the job failed.

      This reducer failed to launch all 4 task attempts with a Token Expiration error and the jobhistory file only gets an event when the task attempt transitions to launched. The webapp JobInfo object only counts the task attempts in the jobhistory file to display under the "Attempt Type" table, so since this task didn't have an attempt with it, it did show it on the UI.

      We need to reconcile the task list with the task attempts or also shows more stats for the tasks vs task attempts.

        Issue Links

          Activity

          vinodkv Vinod Kumar Vavilapalli added a comment -

          Moving bugs out of previously closed releases into the next minor release 2.8.0.

          jianhe Jian He added a comment -

          An improvement on the UI.
          Unlikely, this will get done. move out

          jlowe Jason Lowe added a comment -

          This is a duplicate of MAPREDUCE-5982 which was fixed in 2.7.2 and 2.6.4.


            People

            • Assignee:
              Unassigned
              Reporter:
              tgraves Thomas Graves
            • Votes:
              0 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development