Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.23.3
    • Fix Version/s: 0.23.3, 2.0.2-alpha
    • Component/s: None
    • Labels:
      None

      Description

      Caused by: java.lang.NullPointerException
              at org.apache.hadoop.yarn.server.resourcemanager.RMNMInfo.getLiveNodeManagers(RMNMInfo.java:96)
              at sun.reflect.GeneratedMethodAccessor50.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:93)
              at com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:27)
              at com.sun.jmx.mbeanserver.MBeanIntrospector.invokeM(MBeanIntrospector.java:208)
              at com.sun.jmx.mbeanserver.PerInterface.getAttribute(PerInterface.java:65)
              at com.sun.jmx.mbeanserver.MBeanSupport.getAttribute(MBeanSupport.java:216)
              at javax.management.StandardMBean.getAttribute(StandardMBean.java:358)
              at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getAttribute(DefaultMBeanServerInterceptor.java:666)
      

      Looks like rmcontext.getRMNodes() is not kept in sync with scheduler.getNodeReport(), so that the report can be null even though the context still knowns about the node.

      The simple fix is to add in a null check.

      1. MR-4233.txt
        6 kB
        Robert Joseph Evans

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1077 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1077/)
        MAPREDUCE-4233. NPE can happen in RMNMNodeInfo. (bobby) (Revision 1337363)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1337363
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestRMNMInfo.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/RMNMInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1041 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1041/)
        MAPREDUCE-4233. NPE can happen in RMNMNodeInfo. (bobby) (Revision 1337363)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1337363
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestRMNMInfo.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/RMNMInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #254 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/254/)
        svn merge -c 1337363 FIXES: MAPREDUCE-4233. NPE can happen in RMNMNodeInfo. (bobby) (Revision 1337365)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1337365
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestRMNMInfo.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/RMNMInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2251 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2251/)
        MAPREDUCE-4233. NPE can happen in RMNMNodeInfo. (bobby) (Revision 1337363)

        Result = ABORTED
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1337363
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestRMNMInfo.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/RMNMInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2234 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2234/)
        MAPREDUCE-4233. NPE can happen in RMNMNodeInfo. (bobby) (Revision 1337363)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1337363
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestRMNMInfo.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/RMNMInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2308 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2308/)
        MAPREDUCE-4233. NPE can happen in RMNMNodeInfo. (bobby) (Revision 1337363)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1337363
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestRMNMInfo.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/RMNMInfo.java
        Robert Joseph Evans added a comment -

        Thanks for the review Ahmed.

        Ahmed Radwan added a comment -

        Bobby, I see your point and I agree that keeping them missing is the simplest solution to avoid complicating the issue. +1 for the patch in the current shape. Thanks!

        Robert Joseph Evans added a comment -

        Ahmed,

        We were using the capacity scheduler at the time.

        I debated how I should special case this, and I am fine changing it so let me know if you feel strongly about it.

        I thought about simply returning a 0 for NumContainers, UsedMemoryMB and AvailableMemoryMB, because that is what the true values are. no containers are running using no memory and because the node is unavailable there is no available memory. This is what the web service at /ws/v1/cluster/nodes does for these values, but I thought not having them there was a better flag to indicate that something was wrong with the node. I don't really want to return something like

        {
          ...
          "NumContainers" : "Scheduler report unavailable",
          ...
        }
        

        Because they normally return numbers and it doesn't really feel right to me to return a string when we normally return a number, but returning a -1 as a flag also doesn't feel quite right.

        Ahmed Radwan added a comment -

        Thanks Bobby!

        Just to have complete context, were Fifo or Capacity scheduler used when you saw this problem?

        +1 for the patch. Nit: I would suggest adding a special value to the InfoMap in case (report == null) that corresponds to the keys: "NumContainersMB", "UsedMemoryMB" and "AvailableMemoryMB". Something like "Scheduler report unavailable". This will help identifying these cases in the node managers' statuses, on the other hand if these key/value pairs are missing from the InfoMap, there is no clue why they are missing.

        Robert Joseph Evans added a comment -

        I manually verified that HADOOP-8354 is the cause of the test failure. The test passes when run manually.

        Robert Joseph Evans added a comment -

        I don't really know why the tests failed. They pass for me when I run them manually. It almost looks like for some reason the tests were run against an unchanged version of RMNMInfo. The error for org.apache.hadoop.mapreduce.v2.TestRMNMInfo.testRMNMInfoMissmatch shows

        java.lang.NullPointerException
        	at org.apache.hadoop.yarn.server.resourcemanager.RMNMInfo.getLiveNodeManagers(RMNMInfo.java:96)
        	at org.apache.hadoop.mapreduce.v2.TestRMNMInfo.testRMNMInfoMissmatch(TestRMNMInfo.java:146)
                ...
        

        As the cause of the error. But RMNMInfo.java:96 in the new code is

         if(report != null) { 

        which is impossible to throw a null pointer exception.

        My guess is that this is related to the test patch changes, and maven is somehow confused by running the tests from testpatch without installing the jars in the M2 directory first.

        Robert Joseph Evans added a comment -

        @Bikas,

        The situation we are in with one of our clusters is not an intermittent race. The cluster is kind of stuck in this case right now, although the race is also a possibility.

        I was curious to see what were the situations where the scheduler's node list was updated. It is updated whenever there is a NODE_ADDED or a NODE_REMOVED event sent to the scheduler. The NODE_ADDED events happen when a node registers for the first time, when a node reconnects, and when a node's status transitions from unhealth to healthy. Similarly the NODE_REMOVED event is sent when a node transitions from healthy to unhealthy, when the node is deactivated, or when a node reconnects (it is removed and then added back in). From that it appears that scheduler is intended to only store the list of healthy nodes. By contrast the list of nodes in the RM Context is updated when nodes register, reconnect, or deactivate. The difference between the two is unhealthy/healthy transitions.

        I did not dig much further to see if there was more of a disconnect between the two lists. Especially because in the other places that access either of these node lists they check for null return values so I assumed that it was simply a missed null check here as well.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12526025/MR-4233.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager:

        org.apache.hadoop.mapreduce.v2.TestRMNMInfo

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2368//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2368//console

        This message is automatically generated.

        Robert Joseph Evans added a comment -

        This patch should fix the issue. I also changed the NumContainersMB field to be called NumContainers. It looked like a typo because the number of containers has nothing to do with MegaBytes.

        Bikas Saha added a comment -

        Does this happen because a node got added back (say because it became healthy) and the nodes list in RMContext got updated before the nodes list in Scheduler? Then the solution to check for null would be valid because its a temporary synch issue.

        Any chance that the above was due to a bug which caused RMcontext nodes list and Scheduler nodes list to become permanently out of sync?


          People

          • Assignee:
            Robert Joseph Evans
            Reporter:
            Robert Joseph Evans
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development