Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-4092

commitJob Exception does not fail job (regression in 0.23 vs 0.20)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.23.2
    • Fix Version/s: 0.23.3, 2.0.2-alpha
    • Component/s: mrv2
    • Labels:
      None

      Description

      If commitJob throws an exception JobImpl will swallow the exception with a warning and succeed the Job. This is a break from 0.20 and 1.0 where commitJob exception will fail the job

      Exception logged in the AM as WARN
      org.apache.hadoop.mapreduce.v2.app.job.impl.JobImpl: Could not do commit for Job
      Job still finishes as succeeded

      1. MAPREDUCE-4092.patch
        4 kB
        Jonathan Eagles
      2. MAPREDUCE-4092.patch
        4 kB
        Jonathan Eagles

        Activity

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1039 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1039/)
        MAPREDUCE-4092. commitJob Exception does not fail job (Jon Eagles via bobby) (Revision 1308507)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1308507
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/JobImpl.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/test/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TestJobImpl.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1004 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1004/)
        MAPREDUCE-4092. commitJob Exception does not fail job (Jon Eagles via bobby) (Revision 1308507)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1308507
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/JobImpl.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/test/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TestJobImpl.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #217 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/217/)
        svn merge -c 1308507 from trunk FIXES: MAPREDUCE-4092. commitJob Exception does not fail job (Jon Eagles via bobby) (Revision 1308510)

        Result = UNSTABLE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1308510
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/JobImpl.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/test/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TestJobImpl.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2047 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2047/)
        MAPREDUCE-4092. commitJob Exception does not fail job (Jon Eagles via bobby) (Revision 1308507)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1308507
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/JobImpl.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/test/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TestJobImpl.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #1972 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1972/)
        MAPREDUCE-4092. commitJob Exception does not fail job (Jon Eagles via bobby) (Revision 1308507)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1308507
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/JobImpl.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/test/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TestJobImpl.java
        Jonathan Eagles added a comment -

        Great!

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #1984 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1984/)
        MAPREDUCE-4092. commitJob Exception does not fail job (Jon Eagles via bobby) (Revision 1308507)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1308507
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/JobImpl.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/test/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TestJobImpl.java
        Robert Joseph Evans added a comment -

        Thanks Jon, I just put this into branch-0.23 branch-2 and trunk.

        Robert Joseph Evans added a comment -

        The patch looks good to me. The only one minor issue I have is that in checkJobCompleteSuccess we are still logging at a warn, but we are failing the job, so I would expect that to be logged at an error instead. I can fix that when I check it in +1

        The test failures look to be caused by a runaway process.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12520682/MAPREDUCE-4092.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.mapred.TestJobCounters
        org.apache.hadoop.mapred.TestMiniMRChildTask
        org.apache.hadoop.mapreduce.v2.TestMiniMRProxyUser
        org.apache.hadoop.mapreduce.v2.TestMROldApiJobs
        org.apache.hadoop.mapreduce.TestMapReduceLazyOutput
        org.apache.hadoop.mapreduce.v2.TestSpeculativeExecution
        org.apache.hadoop.mapred.TestJobCleanup
        org.apache.hadoop.mapred.TestReduceFetch
        org.apache.hadoop.mapred.TestReduceFetchFromPartialMem
        org.apache.hadoop.mapreduce.v2.TestMRJobs
        org.apache.hadoop.mapreduce.TestChild
        org.apache.hadoop.mapred.TestLazyOutput
        org.apache.hadoop.mapreduce.v2.TestUberAM
        org.apache.hadoop.mapred.TestMiniMRClientCluster
        org.apache.hadoop.mapreduce.lib.output.TestJobOutputCommitter
        org.apache.hadoop.mapred.TestJobSysDirWithDFS

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2122//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2122//console

        This message is automatically generated.


          People

          • Assignee:
            Jonathan Eagles
            Reporter:
            Jonathan Eagles
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development