Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-4075

Incorrect NM's hyperlink and NM's information

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      While accessing task attempt log of sucessfully completed uber-job from jobhistory/attempts/job_<id>/m/SUCCESSFUL, noticed the following

      • NM information displayed while accessing logs hyperlink is
        Aggregation may not be complete, Check back later or try the nodemanager at localhost:1234
      • Node's hyperlink is displayed as localhost:8042

      In the above case, I think we should update localhost and port numbers to reflect the actual values to make hyperlink work.

        Activity

        Bhallamudi Venkata Siva Kamesh added a comment -

        Thanks Jason, MAPREDUCE-3682 also addressing the same issue. So resolving this one as duplicate.

        Jason Lowe added a comment -

        Is this a duplicate of MAPREDUCE-3682?

        Bhallamudi Venkata Siva Kamesh added a comment -

        I think, we should update the localhost with the actual NM hostname. Also we need to update the

        • port 1234 with NM_LOCALIZER_PORT
        • port 8042 with NM_WEBAPP_PORT.

          People

          • Assignee:
            Unassigned
            Reporter:
            Bhallamudi Venkata Siva Kamesh
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development