Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha, 3.0.0
    • Fix Version/s: 2.1.0-beta, 0.23.9
    • Component/s: client
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      while executing

      bin/mapred  job -list-attempt-ids job_id map running

      , we are getting IllegalArgumentexception.

      1. MAPREDUCE-4019-b23-2.txt
        9 kB
        Ashwin Shankar
      2. MAPREDUCE-4019-6.txt
        9 kB
        Ashwin Shankar
      3. MAPREDUCE-4019-4.txt
        9 kB
        Ashwin Shankar
      4. MAPREDUCE-4019.txt
        9 kB
        Ashwin Shankar
      5. MAPREDUCE-4019.patch
        2 kB
        B Anil Kumar
      6. MAPREDUCE-4019.patch
        7 kB
        Devaraj K

        Issue Links

          Activity

          B Anil Kumar added a comment -

          Please review the patch.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12518599/MAPREDUCE-4019.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.mapred.TestWritableJobConf

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2063//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2063//console

          This message is automatically generated.

          B Anil Kumar added a comment -

          I manually tested the correctness of this patch. And the above test failure is not related to this patch.

          Devaraj K added a comment -

          Thanks Anil for the patch.

          Patch mostly looks good to me except few minor nits/doubts on the patch.

          • Can we show the states as MAP, REDUCE in the usage info instead of having taskTypes map(likewise before mrv2 changes)?
          • As of now there is no support for JOB_SETUP, JOB_CLEANUP. Do we need to display these also?
          B Anil Kumar added a comment -

          Thanks for your review Devaraj.

          Can we show the states as MAP, REDUCE in the usage info instead of having taskTypes map(likewise before mrv2 changes)?

          As previously we have taskTypes as map and reduce, So I kept the same.
          Do we also need to show the states as MAP and REDUCE? Based on your suggestion, I will change the patch.

          As of now there is no support for JOB_SETUP, JOB_CLEANUP. Do we need to display these also?

          Yes, I think we no need to display these two. I will remove them in the next patch.

          Devaraj K added a comment -

          I would suggest to have the task types are MAP and REDUCE instead of having as map, reduce and again getting from the taskTypes map.

          Devaraj K added a comment -

          And also can you add some tests to demonstrate the issue.

          Devaraj K added a comment -

          I have updated the patch with test case.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12522397/MAPREDUCE-4019.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2210//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2210//console

          This message is automatically generated.

          Harsh J added a comment -

          This isn't a blocker for any release.

          The issue is that you needed to specify "JOB_ID MAP running" instead of lower-case "map". We can improve this by making the enum check case-insensitive.

          Ashwin Shankar added a comment -

          Hi,
          I wanted to help move this patch. I've made changes to remove JOB_SETUP,JOB_CLEANUP options. I've added code to validate task-type options at the beginning(CLI.run()) rather than passing it to other classes which would throw an exception somewhere down the call hierarchy(current implementation). I've also made the options for --list-attempt-ids case insensitive, so options 'map','reduce' will work. I've added couple of unit tests to test all these changes.Please note that I've reused some of the code from the previous patch contributed by B.Kumar.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12585071/MAPREDUCE-4019-4.txt
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/3680//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/3680//console

          This message is automatically generated.

          Jason Lowe added a comment -

          Thanks for picking up the torch on this, Ashwin. Couple of comments:

          • Whitespace was removed before/after a number of methods which would be nice to have back to match the style of the rest of the code
          • getCluster should be named something like createCluster to indicate it is creating a new object each time it's called
          • getTaskTypes() can simply be StringUtils.join(taskTypes, " ")
          Ashwin Shankar added a comment -

          Thanks Jason, patch updated. I forgot to mention this before,this patch doesn't apply to branch-23 . I'll upload a separate patch for 23 once I gets the green signal for this one.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12586540/MAPREDUCE-4019-6.txt
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/3745//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/3745//console

          This message is automatically generated.

          Jason Lowe added a comment -

          +1, will commit shortly.

          Ashwin Shankar added a comment -

          MAPREDUCE-4019-b23-2.txt is the patch for branch-23. Please note that Jenkins will complain since this won't apply to trunk.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12587706/MAPREDUCE-4019-b23-2.txt
          against trunk revision .

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/3768//console

          This message is automatically generated.

          Hudson added a comment -

          Integrated in Hadoop-trunk-Commit #3915 (See https://builds.apache.org/job/Hadoop-trunk-Commit/3915/)
          MAPREDUCE-4019. -list-attempt-ids is not working. Contributed by Ashwin Shankar, Devaraj K, and B Anil Kumar (Revision 1492868)

          Result = SUCCESS
          jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1492868
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/tools/CLI.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools/TestCLI.java
          Jason Lowe added a comment -

          +1 for the 0.23 patch which will also apply to branch-2. There are a couple of the whitespace changes that didn't make it into the 0.23 patch, but they're small nits that I can cleanup during the commmit.

          Jason Lowe added a comment -

          Thanks, Ashwin, Devaraj, and B Anil! I committed this to trunk, branch-2, branch-2.1-beta, and branch-0.23.

          Hudson added a comment -

          Integrated in Hadoop-Yarn-trunk #240 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/240/)
          MAPREDUCE-4019. -list-attempt-ids is not working. Contributed by Ashwin Shankar, Devaraj K, and B Anil Kumar (Revision 1492868)

          Result = SUCCESS
          jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1492868
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/tools/CLI.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools/TestCLI.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #638 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/638/)
          svn merge -c 1492877 FIXES: MAPREDUCE-4019. -list-attempt-ids is not working. Contributed by Ashwin Shankar, Devaraj K, and B Anil Kumar (Revision 1492882)

          Result = UNSTABLE
          jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1492882
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/tools/CLI.java
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools/TestCLI.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1457 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1457/)
          MAPREDUCE-4019. -list-attempt-ids is not working. Contributed by Ashwin Shankar, Devaraj K, and B Anil Kumar (Revision 1492868)

          Result = FAILURE
          jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1492868
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/tools/CLI.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools/TestCLI.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #1430 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1430/)
          MAPREDUCE-4019. -list-attempt-ids is not working. Contributed by Ashwin Shankar, Devaraj K, and B Anil Kumar (Revision 1492868)

          Result = FAILURE
          jlowe : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1492868
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/tools/CLI.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/tools/TestCLI.java

            People

            • Assignee:
              Ashwin Shankar
              Reporter:
              B Anil Kumar
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development