Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.1
    • Fix Version/s: 0.23.1
    • Component/s: mrv2, test
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      TestDistributedShell#testDSShell is failing the assert on line 90 on branch-23.

      1. MR-3709.2.patch
        3 kB
        Hitesh Shah
      2. MR-3709.1.patch
        2 kB
        Hitesh Shah

        Activity

        Eli Collins created issue -
        Hitesh Shah added a comment -

        @Eli, could you check if JAVA_HOME is set in the environment when running this test and if not, re-try after setting it in the env?

        Eli Collins added a comment -

        Yes, I have JAVA_HOME set.

        Mahadev konar made changes -
        Field Original Value New Value
        Component/s mrv2 [ 12314301 ]
        Component/s mrv1 [ 12315344 ]
        Eli Collins added a comment -

        I think this is environmental, noticed a container getting killed in the log.

        "Container [pid=14954,containerID=container_1327360294062_0001_01_000001] is running beyond virtual memory limits. Current usage: 78.4mb of 2.0gb physical memory used; 4.3gb of 4.2gb virtual memory used. Killing container"

        Perhaps a change like HADOOP-7154 needs to be made in yarn.

        Hitesh Shah added a comment -

        @Eli, I don't have a rhel6 host to try and reproduce this and a rhel5 host does not show this issue.

        Yarn already has fixes in place for malloc arena when running a proper cluster ( yarn-config.sh sets it if not set and yarn sets malloc_arena_max ( if present in the node manager's env ) into the application's env unless its overridden by the user's config. [ Refer to ContainerLaunch#sanitiveEnv, YarnConfiguration.NM_ADMIN_USER_ENV and YarnConfiguration.DEFAULT_NM_ADMIN_USER_ENV).

        One option to try and fix the test in your case would be change the pom file to have this:

        @@ -104,6 +104,7 @@
        <configuration>
        <environmentVariables>
        <JAVA_HOME>$

        Unknown macro: {java.home}

        </JAVA_HOME>
        + <MALLOC_ARENA_MAX>4</MALLOC_ARENA_MAX>
        </environmentVariables>
        </configuration>
        </plugin>

        Could you try the above change and see if it resolves the test failure in your env? The above change will result in launch_container.sh setting the malloc arena max value to 4.

        Eli Collins added a comment -

        Diff'ing TestDistributedShell-output.txt from a successful run (on another host) and my machine does indicate the failure is due to the container getting killed due to running beyond its VM limits.

        The test however still fails when making the following change to the pom.xml in hadoop-yarn-applications-distributedshell.

        hadoop-trunk1 $ svn diff
        Index: hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        ===================================================================
        --- hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml	(revision 1235995)
        +++ hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml	(working copy)
        @@ -104,6 +104,7 @@
                 <configuration>
                   <environmentVariables>
                     <JAVA_HOME>${java.home}</JAVA_HOME>
        +            <MALLOC_ARENA_MAX>4</MALLOC_ARENA_MAX>
                   </environmentVariables>
                </configuration>
               </plugin>
        
        Hitesh Shah made changes -
        Assignee Hitesh Shah [ hitesh ]
        Hitesh Shah added a comment -

        @Eli, given that MAPREDUCE-3765 is now in, the latest patch should be able to use smaller sized containers which hopefully should solve the problem. Could you please try the patch and let me know if it fixes the issue in your env.

        I am also downgrading this to a non-blocker as it is not reproducible in most environments. Please let me know if you see any issues with doing this.

        Hitesh Shah made changes -
        Attachment MR-3709.1.patch [ 12513463 ]
        Hitesh Shah made changes -
        Priority Blocker [ 1 ] Major [ 3 ]
        Hitesh Shah made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hitesh Shah made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12513463/MR-3709.1.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1790//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1790//console

        This message is automatically generated.

        Hitesh Shah added a comment -

        Real fix this time.

        Hitesh Shah made changes -
        Attachment MR-3709.2.patch [ 12513512 ]
        Hitesh Shah made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Eli Collins added a comment -

        Oddly the test no longer fails on my system w/o this patch. Something else must have changed in the meantime.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12513512/MR-3709.2.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1800//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1800//console

        This message is automatically generated.

        Hitesh Shah added a comment -

        @Eli, from what I figured out, the test failure was likely due to what the default jvm heap size configured on the system and what the allocated container size is. If the default heap allocated is larged than the allocated container, the memory check would kick in and fail the test. In the latest patch, I tweaked the distributed shell code itself to set the appropriate heap size and make sure that it is within the required bounds.

        Mahadev konar added a comment -

        +1 for the patch. Looks good to me.

        Mahadev konar added a comment -

        I just committed this. Thanks Hitesh!

        Mahadev konar made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Resolution Fixed [ 1 ]
        Mahadev konar made changes -
        Fix Version/s 0.23.1 [ 12318883 ]
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1753 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1753/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241325
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #1680 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1680/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241325
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Commit #497 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/497/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev) - Merging r1241325 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241327
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Common-0.23-Commit #507 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/507/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev) - Merging r1241325 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241327
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #1692 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1692/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241325
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Commit #514 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/514/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev) - Merging r1241325 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241327
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #949 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/949/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241325
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #162 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/162/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev) - Merging r1241325 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241327
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Build #184 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/184/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev) - Merging r1241325 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241327
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #982 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/982/)
        MAPREDUCE-3709. TestDistributedShell is failing. (Hitesh Shah via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1241325
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/test/java/org/apache/hadoop/yarn/applications/distributedshell/TestDistributedShell.java
        Arun C Murthy made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Patch Available Patch Available Open Open
        46m 43s 1 Hitesh Shah 06/Feb/12 19:38
        Open Open Patch Available Patch Available
        14d 4h 5m 2 Hitesh Shah 06/Feb/12 22:29
        Patch Available Patch Available Resolved Resolved
        3h 31m 1 Mahadev konar 07/Feb/12 02:01
        Resolved Resolved Closed Closed
        27d 48m 1 Arun C Murthy 05/Mar/12 02:49

          People

          • Assignee:
            Hitesh Shah
            Reporter:
            Eli Collins
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development