Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.23.1
    • Component/s: mrv2
    • Labels:
      None

      Description

      The following tests fail:
      org.apache.hadoop.mapred.TestQueueManagerRefresh.testRefreshWithRemovedQueues
      org.apache.hadoop.mapred.TestQueueManagerRefresh.testRefreshOfSchedulerProperties

      It looks like its simply trying to remove one of the queues but the remove is failing.It looks like MAPREDUCE-3328. mapred queue -list output inconsistent and missing child queues - change the getChilren routine to do a new JobQueueInfo on each one when returning it which is making the remove routine fail since they aren't the same object now.

      1. MAPREDUCE-3651.patch
        2 kB
        Thomas Graves
      2. MAPREDUCE-3651.patch
        0.8 kB
        Thomas Graves

        Activity

        Thomas Graves added a comment -

        reverted change from patch.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12510061/MAPREDUCE-3651.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1582//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1582//console

        This message is automatically generated.

        Thomas Graves added a comment -

        Test TestQueueManagerRefresh was already testing this and failing, so no extra tests needed.

        Thomas Graves added a comment -

        looks like the mapred queue list command fails with this on parent queues, need to investigate further.

        Thomas Graves added a comment -

        So the problem with the mapred queue -list is actually in the JobClient in routine getJobQueueInfoArray. It is currently only converting the root queues from QueueInfo to JobQueueInfo. This routine needs to handle converting the child queues also.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12510203/MAPREDUCE-3651.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        -1 javac. The applied patch generated 2186 javac compiler warnings (more than the trunk's current 2185 warnings).

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1590//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1590//console

        This message is automatically generated.

        Mahadev konar added a comment -

        The patch looks good. Thomas, can you please investigate the javac warnings?

        Thomas Graves added a comment -

        looking.

        Thomas Graves added a comment -

        The issue is I added another reference to JobQueueInfo which is deprecated. Should I just add an exception for it?
        Currently there are 3 references to it and then I added anther.

        Here is the diff:

        < [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1052,9] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        < [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1072,9] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        < [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1091,9] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        < [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1111,9] [deprecation] org.apache.hadoop.mapred.JobStatus in org.apache.hadoop.mapred has been deprecated
        < [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1141,9] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        < [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1163,9] [deprecation] org.apache.hadoop.mapred.QueueAclsInfo in org.apache.hadoop.mapred has been deprecated

        > [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1050,10] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        > [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1066,9] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        > [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1086,9] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        > [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1105,9] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        > [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1125,9] [deprecation] org.apache.hadoop.mapred.JobStatus in org.apache.hadoop.mapred has been deprecated
        > [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1155,9] [deprecation] org.apache.hadoop.mapred.JobQueueInfo in org.apache.hadoop.mapred has been deprecated
        > [WARNING] /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java:[1177,9] [deprecation] org.apache.hadoop.mapred.QueueAclsInfo in org.apache.hadoop.mapred has been deprecated

        Mahadev konar added a comment -

        Yup, just go ahead and add an exception for that.

        Mahadev konar added a comment -

        Forget abt my comment. There isnt an exception file for deprecation. Ill go ahead and commit this as it is.

        Mahadev konar added a comment -

        I just committed this. Thanks Thomas!

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Commit #357 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/357/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev) - Merging r1230292 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230295
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Common-0.23-Commit #367 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/367/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev) - Merging r1230292 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230295
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #1529 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1529/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230292
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1602 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1602/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230292
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Commit #378 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/378/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev) - Merging r1230292 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230295
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #1548 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1548/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230292
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #923 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/923/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230292
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #136 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/136/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev) - Merging r1230292 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230295
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Build #158 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/158/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev) - Merging r1230292 from trunk.

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230295
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #956 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/956/)
        MAPREDUCE-3651. TestQueueManagerRefresh fails. (Thomas Graves via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1230292
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobClient.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/JobQueueInfo.java

          People

          • Assignee:
            Thomas Graves
            Reporter:
            Thomas Graves
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development