Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-3639

TokenCache likely broken for FileSystems which don't issue delegation tokens

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.1
    • Component/s: mrv2
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      Fixed TokenCache to work with absent FileSystem canonical service-names.

      Description

      1. MR3639.txt
        2 kB
        Siddharth Seth

        Issue Links

          Activity

          Siddharth Seth created issue -
          Siddharth Seth made changes -
          Field Original Value New Value
          Attachment MR3639.txt [ 12509961 ]
          Siddharth Seth made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Assignee Siddharth Seth [ sseth ]
          Siddharth Seth added a comment -

          MR + viewFs will fail without this. Marking as blocker.

          Siddharth Seth made changes -
          Priority Critical [ 2 ] Blocker [ 1 ]
          Vinod Kumar Vavilapalli added a comment -

          Trivial patch. +1. Waiting for Jenkins.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12509961/MR3639.txt
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          -1 findbugs. The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1572//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1572//artifact/trunk/hadoop-mapreduce-project/patchprocess/newPatchFindbugsWarningshadoop-mapreduce-client-app.html
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1572//console

          This message is automatically generated.

          Thomas Graves added a comment -

          this fixes the following tests then?

          org.apache.hadoop.mapreduce.security.TestTokenCache.testGetTokensForHftpFS
          org.apache.hadoop.mapreduce.security.TestTokenCache.testGetTokensForViewFS

          Daryn Sharp added a comment -

          Hang on with the commit. I don't think this patch is complete, need to cross check with 205.

          Daryn Sharp added a comment -

          TokenCache#obtainTokensForNamenodesInternal needs the same null check on getCanonicalServiceName as 205 does.

          Siddharth Seth added a comment -

          @Daryn, That check should not be present. getCanonicalServiceName will return null for filesystems like viewfs. With that additional check - TokenCache will not get tokens for the underlying filesystems.

          @Thomas - didn't run the ant tests earlier. Looks like testGetTokensForViewFS is fixed, but HftpFS is not. Do you know when these tests started failing ?

          Thomas Graves added a comment -

          Looks like the Jan 5th or 6th. I saw this and was hoping it fixed them. If you think the other is different issue we can file separate jira.

          Siddharth Seth added a comment -

          From running ant -Dtestcase=TestTokenCache. I would lean towards fixing that via another jira.
          nofromat
          Testcase: testTokenCache took 12.438 sec
          Testcase: testLocalJobTokenCache took 13.397 sec
          Testcase: testGetTokensForNamenodes took 0.002 sec
          Testcase: testGetTokensForHftpFS took 0.16 sec
          Caused an ERROR
          java.net.UnknownHostException: host
          java.lang.IllegalArgumentException: java.net.UnknownHostException: host
          at org.apache.hadoop.security.SecurityUtil.buildTokenService(SecurityUtil.java:425)
          at org.apache.hadoop.security.SecurityUtil.buildDTServiceName(SecurityUtil.java:308)
          at org.apache.hadoop.mapreduce.security.TestTokenCache.testGetTokensForHftpFS(TestTokenCache.java:324)
          Caused by: java.net.UnknownHostException: host

          Testcase: testGetJTPrincipal took 0.011 sec
          Testcase: testGetTokensForViewFS took 0.01 sec
          nofromat

          Daryn Sharp added a comment -

          I think you can use NetUtils.addStaticResolution to dummy out the lookups of "host".

          That check should not be present. getCanonicalServiceName will return null for filesystems like viewfs. With that additional check - TokenCache will not get tokens for the underlying filesystems.

          Sigh, that's right, and one of the things I was trying to fix in an alt patch. The view fs token caching is getting quite murky, but this at least makes it work better, so +1...

          Vinod Kumar Vavilapalli added a comment -

          Argh.. this has become quite a mess. Seems like the underlying problem is that FileSystem.getCanonicalServiceName() is null for Viewfs. Not sure of a clean solution, but I can see that the current patch should let clients with viewfs get delegation tokens correctly.

          Let us separate the test-failure testGetTokensForHftpFS(), though if I understand this whole mess correctly, that is caused by HADOOP-7808 itself.

          Vinod Kumar Vavilapalli added a comment -

          Just committed this to trunk and branch-0.23. Thanks Sid!

          Vinod Kumar Vavilapalli made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Hadoop Flags Reviewed [ 10343 ]
          Release Note Fixed TokenCache to work with absent FileSystem canonical service-names.
          Fix Version/s 0.23.1 [ 12318883 ]
          Resolution Fixed [ 1 ]
          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #357 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/357/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)
          svn merge --ignore-ancestry -c 1229444 ../../trunk/

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229446
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1517 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1517/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229444
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #1590 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1590/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229444
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #347 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/347/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)
          svn merge --ignore-ancestry -c 1229444 ../../trunk/

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229446
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Thomas Graves added a comment -

          filed MAPREDUCE-3650 for testGetTokensForHftpFS failure.

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #368 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/368/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)
          svn merge --ignore-ancestry -c 1229444 ../../trunk/

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229446
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1536 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1536/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229444
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #921 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/921/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229444
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Build #134 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/134/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)
          svn merge --ignore-ancestry -c 1229444 ../../trunk/

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229446
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Build #156 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/156/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)
          svn merge --ignore-ancestry -c 1229444 ../../trunk/

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229446
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #954 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/954/)
          MAPREDUCE-3639. Fixed TokenCache to work with absent FileSystem canonical service-names. (Siddharth Seth via vinodkv)

          vinodkv : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1229444
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/security/TokenCache.java
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapreduce/security/TestTokenCache.java
          Daryn Sharp added a comment -

          Argh.. this has become quite a mess. [...] if I understand this whole mess correctly, that is caused by HADOOP-7808 itself.

          HADOOP-7808 brought in behavior, but the change was part HADOOP-7602 to fix har handling. That part has already been improved on trunk.

          However, the approach of allowing TokenCache to decide whether a filesystem has tokens, and assuming it has only one token based the getCanonicalServiceName is fundamentally flawed. I'll file a jira and throw up an incomplete patch to demonstrate a possibly cleaner implementation.

          Daryn Sharp made changes -
          Link This issue relates to HADOOP-7967 [ HADOOP-7967 ]
          Vinod Kumar Vavilapalli added a comment -

          Agreed. Looks like you opened HADOOP-7967 for that, let us take it forward there. Thanks.

          Arun C Murthy made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Siddharth Seth
              Reporter:
              Siddharth Seth
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development