Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-3637

Health checker interval does not appear to work - according to web ui

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.23.0
    • Fix Version/s: None
    • Component/s: mrv2
    • Labels:
      None

      Description

      reported by QE, I think this is probably a web ui not updating issue, but not positive.

      1. The property yarn.nodemanager.health-checker.interval-ms on the RM and the DN are set to 135000 ms, or 2 minutes and
      15 sec.

      $ grep -A 2 "health-checker.interval-ms" yarn-site.xml
      <name>yarn.nodemanager.health-checker.interval-ms</name>
      <value>135000</value>
      </property>

      2. According to the web ui (e.g http://rm:8088/cluster/nodes), the 'last health-update'
      column does not get updated, except when the RM is restated.

        Activity

        Thomas Graves added a comment -

        seems to be working.


          People

          • Assignee:
            Unassigned
            Reporter:
            Thomas Graves
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development