Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: mrv2
    • Labels:
      None

      Description

      Suppose say in a single host, there have been multiple NMs configured. In this case, there should be mechanism to detect the NMs comeback.

        Issue Links

          Activity

          Bhallamudi Venkata Siva Kamesh added a comment -

          If the NMs have been configured to use static ports, we can store the lost NMs information by their NodeID and hence RM can detect the NM's comeback.
          I think there should be a mechanism, even if the NMs have been configured to use ephemeral ports.

          Vinod Kumar Vavilapalli added a comment -

          What are your actual observations when you tried to restart an NM? Few bugs were fixed in the recent past that should have fixed this.

          Vinod Kumar Vavilapalli added a comment -

          Downgrading priority till we get more details.

          Jason Lowe added a comment -

          Marking this as a duplicate of MAPREDUCE-3363. The core issue in both is that the RM is unable to differentiate between a new NM adding to the cluster and a lost NM rejoining the cluster when ephemeral ports are configured.


            People

            • Assignee:
              Unassigned
              Reporter:
              Bhallamudi Venkata Siva Kamesh
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development