Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.0, 0.24.0
    • Fix Version/s: 0.23.0, 0.24.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      This problem does not happen on 0.23. See details in the next comment.

      1. MAPREDUCE-3204.patch
        0.9 kB
        Alejandro Abdelnur

        Activity

        Suresh Srinivas added a comment -

        Run mvn site:site in hadoop-mapreduce-project directory. I see the following error:

        [INFO] ------------------------------------------------------------------------
        [INFO] BUILD FAILURE
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 1.776s
        [INFO] Finished at: Tue Oct 18 15:35:06 PDT 2011
        [INFO] Final Memory: 11M/81M
        [INFO] ------------------------------------------------------------------------
        [ERROR] Failed to execute goal org.apache.maven.plugins:maven-site-plugin:2.1.1:site (default-cli) on project hadoop-yarn: SiteToolException: ArtifactNotFoundException: The skin does not exist: Failure to find org.apache.maven.skins:maven-default-skin:jar:1.1-SNAPSHOT in https://repository.apache.org/content/repositories/snapshots was cached in the local repository, resolution will not be reattempted until the update interval of apache.snapshots.https has elapsed or updates are forced
        [ERROR]
        [ERROR] Try downloading the file manually from the project website.
        [ERROR]
        [ERROR] Then, install it using the command:
        [ERROR] mvn install:install-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file
        [ERROR]
        [ERROR] Alternatively, if you host your own repository you can deploy the file there:
        [ERROR] mvn deploy:deploy-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
        [ERROR]
        [ERROR]
        [ERROR] org.apache.maven.skins:maven-default-skin:jar:RELEASE
        [ERROR]
        [ERROR] from the specified remote repositories:
        [ERROR] repository.jboss.org (http://repository.jboss.org/nexus/content/groups/public/, releases=true, snapshots=false),
        [ERROR] apache.snapshots (http://repository.apache.org/snapshots, releases=true, snapshots=true),
        [ERROR] apache.snapshots.https (https://repository.apache.org/content/repositories/snapshots, releases=true, snapshots=true),
        [ERROR] central (http://repo1.maven.org/maven2, releases=true, snapshots=false)
        [ERROR] -> [Help 1]
        org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-site-plugin:2.1.1:site (default-cli) on project hadoop-yarn: SiteToolException: ArtifactNotFoundException: The skin does not exist: Failure to find org.apache.maven.skins:maven-default-skin:jar:1.1-SNAPSHOT in https://repository.apache.org/content/repositories/snapshots was cached in the local repository, resolution will not be reattempted until the update interval of apache.snapshots.https has elapsed or updates are forced

        Try downloading the file manually from the project website.

        Then, install it using the command:
        mvn install:install-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file

        Alternatively, if you host your own repository you can deploy the file there:
        mvn deploy:deploy-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

        org.apache.maven.skins:maven-default-skin:jar:RELEASE

        from the specified remote repositories:
        repository.jboss.org (http://repository.jboss.org/nexus/content/groups/public/, releases=true, snapshots=false),
        apache.snapshots (http://repository.apache.org/snapshots, releases=true, snapshots=true),
        apache.snapshots.https (https://repository.apache.org/content/repositories/snapshots, releases=true, snapshots=true),
        central (http://repo1.maven.org/maven2, releases=true, snapshots=false)

        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
        Caused by: org.apache.maven.plugin.MojoExecutionException: SiteToolException: ArtifactNotFoundException: The skin does not exist: Failure to find org.apache.maven.skins:maven-default-skin:jar:1.1-SNAPSHOT in https://repository.apache.org/content/repositories/snapshots was cached in the local repository, resolution will not be reattempted until the update interval of apache.snapshots.https has elapsed or updates are forced

        Try downloading the file manually from the project website.

        Then, install it using the command:
        mvn install:install-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file

        Alternatively, if you host your own repository you can deploy the file there:
        mvn deploy:deploy-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

        org.apache.maven.skins:maven-default-skin:jar:RELEASE

        from the specified remote repositories:
        repository.jboss.org (http://repository.jboss.org/nexus/content/groups/public/, releases=true, snapshots=false),
        apache.snapshots (http://repository.apache.org/snapshots, releases=true, snapshots=true),
        apache.snapshots.https (https://repository.apache.org/content/repositories/snapshots, releases=true, snapshots=true),
        central (http://repo1.maven.org/maven2, releases=true, snapshots=false)

        at org.apache.maven.plugins.site.AbstractSiteRenderingMojo.createSiteRenderingContext(AbstractSiteRenderingMojo.java:254)
        at org.apache.maven.plugins.site.SiteMojo.renderLocale(SiteMojo.java:137)
        at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:120)
        at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
        ... 19 more
        Caused by: org.apache.maven.doxia.tools.SiteToolException: ArtifactNotFoundException: The skin does not exist: Failure to find org.apache.maven.skins:maven-default-skin:jar:1.1-SNAPSHOT in https://repository.apache.org/content/repositories/snapshots was cached in the local repository, resolution will not be reattempted until the update interval of apache.snapshots.https has elapsed or updates are forced

        Try downloading the file manually from the project website.

        Then, install it using the command:
        mvn install:install-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file

        Alternatively, if you host your own repository you can deploy the file there:
        mvn deploy:deploy-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

        org.apache.maven.skins:maven-default-skin:jar:RELEASE

        from the specified remote repositories:
        repository.jboss.org (http://repository.jboss.org/nexus/content/groups/public/, releases=true, snapshots=false),
        apache.snapshots (http://repository.apache.org/snapshots, releases=true, snapshots=true),
        apache.snapshots.https (https://repository.apache.org/content/repositories/snapshots, releases=true, snapshots=true),
        central (http://repo1.maven.org/maven2, releases=true, snapshots=false)

        at org.apache.maven.doxia.tools.DefaultSiteTool.getSkinArtifactFromRepository(DefaultSiteTool.java:175)
        at org.apache.maven.plugins.site.AbstractSiteRenderingMojo.createSiteRenderingContext(AbstractSiteRenderingMojo.java:249)
        ... 23 more
        [ERROR]
        [ERROR]
        [ERROR] For more information about the errors and possible solutions, please read the following articles:
        [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

        Mahadev konar added a comment -

        @Alejandro,
        Any pointers on whats wrong with the mvn site call? It used be working when we checked in the docs for MRv2.

        Prashant Sharma added a comment -

        http://jira.codehaus.org/browse/MSITE-228 is this related ? Then problem is at MSITE end.

        Alejandro Abdelnur added a comment -

        using version 2.2 of the site plugin fixes the problem.

        Mahadev konar added a comment -

        +1 works for me now. Thanks for fixing this Alejandro.

        Alejandro Abdelnur added a comment -

        committed to trunk. to be backported to 0.23 shortly.

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1203 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1203/)
        MAPREDUCE-3204. mvn site:site fails on MapReduce. (tucu)

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1187062
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-project/pom.xml
        • /hadoop/common/trunk/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #1124 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1124/)
        MAPREDUCE-3204. mvn site:site fails on MapReduce. (tucu)

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1187062
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-project/pom.xml
        • /hadoop/common/trunk/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #1140 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1140/)
        MAPREDUCE-3204. mvn site:site fails on MapReduce. (tucu)

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1187062
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-project/pom.xml
        • /hadoop/common/trunk/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #867 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/867/)
        MAPREDUCE-3204. mvn site:site fails on MapReduce. (tucu)

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1187062
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-project/pom.xml
        • /hadoop/common/trunk/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #837 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/837/)
        MAPREDUCE-3204. mvn site:site fails on MapReduce. (tucu)

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1187062
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-project/pom.xml
        • /hadoop/common/trunk/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Commit #100 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/100/)
        Merge -r 1187061:1187062 from trunk to branch. FIXES: MAPREDUCE-3204

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190668
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-project/pom.xml
        • /hadoop/common/branches/branch-0.23/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Common-0.23-Commit #100 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/100/)
        Merge -r 1187061:1187062 from trunk to branch. FIXES: MAPREDUCE-3204

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190668
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-project/pom.xml
        • /hadoop/common/branches/branch-0.23/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Commit #107 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/107/)
        Merge -r 1187061:1187062 from trunk to branch. FIXES: MAPREDUCE-3204

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190668
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-project/pom.xml
        • /hadoop/common/branches/branch-0.23/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #54 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/54/)
        Merge -r 1187061:1187062 from trunk to branch. FIXES: MAPREDUCE-3204

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190668
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-project/pom.xml
        • /hadoop/common/branches/branch-0.23/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Build #72 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/72/)
        Merge -r 1187061:1187062 from trunk to branch. FIXES: MAPREDUCE-3204

        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190668
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-project/pom.xml
        • /hadoop/common/branches/branch-0.23/pom.xml

          People

          • Assignee:
            Alejandro Abdelnur
            Reporter:
            Suresh Srinivas
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development