Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-3200

Job got failed with FileNotFoundException during ResourceLocalization

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 0.23.0
    • Fix Version/s: None
    • Component/s: mrv2
    • Labels:
      None

      Description

      The exception trace is as follows

      2011-10-18 15:37:11,315 WARN org.apache.hadoop.yarn.server.resourcemanager.RMAuditLogger: USER=root	OPERATION=Application Finished - Failed	TARGET=RMAppManager	RESULT=FAILURE	DESCRIPTION=App failed with state: FAILED	PERMISSIONS=Application application_1318930754911_0002 failed 1 times due to AM Container for appattempt_1318930754911_0002_000001 exited with  exitCode: -1000 due to: java.io.FileNotFoundException: file:/tmp/nm-local-dir/usercache/root/appcache/application_1318930754911_0003/container_1318930754911_0002_01_000001.tokens
      	at org.apache.hadoop.fs.RawLocalFileSystem.open(RawLocalFileSystem.java:189)
      	at org.apache.hadoop.fs.DelegateToFileSystem.open(DelegateToFileSystem.java:150)
      	at org.apache.hadoop.fs.AbstractFileSystem.open(AbstractFileSystem.java:595)
      	at org.apache.hadoop.fs.FilterFs.open(FilterFs.java:197)
      	at org.apache.hadoop.fs.FileContext$6.next(FileContext.java:759)
      	at org.apache.hadoop.fs.FileContext$6.next(FileContext.java:756)
      	at org.apache.hadoop.fs.FileContext$FSLinkResolver.resolve(FileContext.java:2321)
      	at org.apache.hadoop.fs.FileContext.open(FileContext.java:756)
      	at org.apache.hadoop.yarn.server.nodemanager.containermanager.localizer.ContainerLocalizer.runLocalization(ContainerLocalizer.java:133)
      	at org.apache.hadoop.yarn.server.nodemanager.DefaultContainerExecutor.startLocalizer(DefaultContainerExecutor.java:86)
      	at org.apache.hadoop.yarn.server.nodemanager.containermanager.localizer.ResourceLocalizationService$LocalizerRunner.run(ResourceLocalizationService.java:855)
      
      

        Activity

        Arun C Murthy added a comment -

        Duplicate of MAPREDUCE-3537.

        Siddharth Seth added a comment -

        Ramgopal, are you still seing this issue ? If so, could you please provide additional details about your environment and steps to reproduce. Thanks

        Ramgopal N added a comment -

        I am using Fairscheduler and submitted 3 jobs in sequence.The second job got failed with this exception.The other 2 jobs passed.

        Vinod Kumar Vavilapalli added a comment -

        This may be same as MAPREDUCE-3159. How often are you hitting this?


          People

          • Assignee:
            Siddharth Seth
            Reporter:
            Ramgopal N
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development