Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.20.205.0
    • Fix Version/s: 0.20.205.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TestSleepJob fails, it was intended to be used in other tests for MAPREDUCE-2981.

      1. MAPREDUCE-3076.patch
        0.8 kB
        Arun C Murthy

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        57s 1 Arun C Murthy 23/Sep/11 01:48
        Patch Available Patch Available Resolved Resolved
        18m 47s 1 Tsz Wo Nicholas Sze 23/Sep/11 02:07
        Resolved Resolved Closed Closed
        25d 23h 19m 1 Matt Foley 19/Oct/11 01:26
        Suresh Srinivas made changes -
        Fix Version/s 1.1.0 [ 12317960 ]
        Matt Foley made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Matt Foley added a comment -

        Closed upon release of 0.20.205.0

        Tsz Wo Nicholas Sze made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Fix Version/s 0.20.206.0 [ 12317960 ]
        Resolution Fixed [ 1 ]
        Tsz Wo Nicholas Sze added a comment -

        I have committed this. Thanks, Arun!

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12496207/MAPREDUCE-3076.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/834//console

        This message is automatically generated.

        Tsz Wo Nicholas Sze made changes -
        Hadoop Flags [Reviewed]
        Tsz Wo Nicholas Sze added a comment -

        +1 patch looks good.

        After the patch, TestSleepJob is ignored.

            [junit] Running org.apache.hadoop.mapreduce.TestSleepJob
            [junit] Tests run: 0, Failures: 0, Errors: 0, Time elapsed: 0.005 sec
        
        Arun C Murthy made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Arun C Murthy made changes -
        Field Original Value New Value
        Attachment MAPREDUCE-3076.patch [ 12496207 ]
        Arun C Murthy added a comment -

        Trivial fix to ignore the file since it isnt' a test-case per-se.

        Arun C Murthy created issue -

          People

          • Assignee:
            Arun C Murthy
            Reporter:
            Arun C Murthy
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development