Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: 0.22.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      FindBugs 1.3.9, ant 1.8.2, RHEL6, Jenkins 1.414 in Tomcat 7.0.14, Sun Java HotSpot(TM) 64-Bit Server VM

      Description

      When running the findbugs target from Jenkins, I get an OutOfMemory error.
      The "effort" in FindBugs is set to Max which ends up using a lot of memory to go through all the classes. The jvmargs passed to FindBugs is hardcoded to 512 MB max.

      We can leave the default to 512M, as long as we pass this as an ant parameter which can be overwritten in individual cases through -D, or in the build.properties file (either basedir, or user's home directory).

        Issue Links

          Activity

          Joep Rottinghuis added a comment -

          findbugs:
          [mkdir] Created dir: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/test/findbugs
          [findbugs] Executing findbugs from ant task
          [findbugs] Running FindBugs...
          [findbugs] Out of memory
          [findbugs] Total memory: 477M
          [findbugs] free memory: 45M
          [findbugs] Analyzed: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/hadoop-mapred-0.22-joep-0.1.jar
          [findbugs] Analyzed: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/hadoop-mapred-examples-0.22-joep-0.1.jar
          [findbugs] Analyzed: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/hadoop-mapred-tools-0.22-joep-0.1.jar
          [findbugs] Analyzed: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/contrib/capacity-scheduler/hadoop-0.22-joep-0.1-capacity-scheduler.jar
          [findbugs] Analyzed: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/contrib/streaming/hadoop-0.22-joep-0.1-streaming.jar
          [findbugs] Analyzed: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/contrib/gridmix/hadoop-0.22-joep-0.1-gridmix.jar
          [findbugs] Analyzed: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/contrib/mumak/hadoop-0.22-joep-0.1-mumak.jar
          [findbugs] Aux: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/ivy/lib/Hadoop/common/ant-1.6.5.jar
          ...cut 40 lines
          [findbugs] Aux: /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/ivy/lib/Hadoop/common/xmlenc-0.52.jar
          [findbugs] Exception in thread "main" java.lang.OutOfMemoryError: Java heap space
          [findbugs] at java.util.ArrayList.<init>(ArrayList.java:112)
          [findbugs] at edu.umd.cs.findbugs.ba.Frame.<init>(Frame.java:110)
          [findbugs] at edu.umd.cs.findbugs.ba.constant.ConstantFrame.<init>(ConstantFrame.java:32)
          [findbugs] at edu.umd.cs.findbugs.ba.constant.ConstantAnalysis.createFact(ConstantAnalysis.java:49)
          [findbugs] at edu.umd.cs.findbugs.ba.constant.ConstantAnalysis.createFact(ConstantAnalysis.java:38)
          [findbugs] at edu.umd.cs.findbugs.ba.BasicAbstractDataflowAnalysis.lookupOrCreateFact(BasicAbstractDataflowAnalysis.java:156)
          [findbugs] at edu.umd.cs.findbugs.ba.BasicAbstractDataflowAnalysis.getResultFact(BasicAbstractDataflowAnalysis.java:69)
          ... cut lines
          [findbugs] at edu.umd.cs.findbugs.FindBugs2.main(FindBugs2.java:1057)
          [findbugs] Java Result: 1
          [findbugs] Output saved to /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/test/findbugs/hadoop-findbugs-report.xml
          [xslt] Processing /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/test/findbugs/hadoop-findbugs-report.xml to /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/test/findbugs/hadoop-findbugs-report.html
          [xslt] Loading stylesheet /usr/local/findbugs/src/xsl/default.xsl
          [xslt] : Error! Premature end of file.
          [xslt] : Error! com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Premature end of file.
          [xslt] Failed to process /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build/test/findbugs/hadoop-findbugs-report.xml

          BUILD FAILED
          /hadoop01/jenkins/jobs/hadoop-mapreduce-test/workspace/mapreduce/build.xml:943: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Premature end of file.
          at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:720)
          at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:313)
          ... cut 15 lines
          at org.apache.tools.ant.Main.startAnt(Main.java:217)
          at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
          at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
          Caused by: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Premature end of file.
          at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:547)
          at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:710)
          ... 20 more
          Caused by: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Premature end of file.
          at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:446)
          at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:234)
          at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:525)
          ... 21 more
          ---------

          Joep Rottinghuis added a comment -

          Even though same entry does not exist in hadoop-common build on 0.20-security, or hadoophdfs on 0.22, the mapreduce build actually already has a parameter for this: findbugs.heap.size


            People

            • Assignee:
              Joep Rottinghuis
              Reporter:
              Joep Rottinghuis
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development