Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-2819

extend JobClient.runJob(JobConf) with the ability to take a timeout, so fail better during test runs

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2.2.0
    • Component/s: test
    • Labels:
      None

      Description

      Tests that submit jobs via JobClient hang until they are killed if something goes wrong in the back end -JobClient does not impose limits on how long runs should take, but JUnit does. If we had an overload of runJob() that took a timeout, JobClient could kill a job that was taking too long, extracting the stack trace and better diagnostics to the test reports.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1936d 23h 20m 1 Steve Loughran 03/Mar/14 10:07
        Steve Loughran made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.2.0 [ 12325050 ]
        Resolution Cannot Reproduce [ 5 ]
        Steve Loughran added a comment -

        Obsoleted in YARN

        Eli Collins made changes -
        Project Hadoop Common [ 12310240 ] Hadoop Map/Reduce [ 12310941 ]
        Key HADOOP-4639 MAPREDUCE-2819
        Issue Type Improvement [ 4 ] Bug [ 1 ]
        Affects Version/s 0.20.0 [ 12313438 ]
        Component/s test [ 12312904 ]
        Component/s test [ 12311440 ]
        Gavin made changes -
        Assignee Steve Loughran [ steve_l ] Steve Loughran [ stevel@apache.org ]
        Gavin made changes -
        Reporter Steve Loughran [ steve_l ] Steve Loughran [ stevel@apache.org ]
        Steve Loughran made changes -
        Field Original Value New Value
        Assignee Steve Loughran [ steve_l ]
        Steve Loughran created issue -

          People

          • Assignee:
            Steve Loughran
            Reporter:
            Steve Loughran
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development