Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-2704

CombineFileInputFormat only works when paths are on the default filesystem

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.23.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      CombineFileInputFormat constructs new Path objects by converting an existing path to a URI, and then only pulling out the "path" part of it. This drops the scheme and host, which makes CombineFileInputFormat fail if the paths are on a filesystem other than the default one.

        Issue Links

          Activity

          Bhallamudi Venkata Siva Kamesh added a comment -

          This seems to be a duplicate of MAPREDUCE-1806

          Vinod Kumar Vavilapalli added a comment -

          This seems to be a duplicate of MAPREDUCE-1806

          Yes, it is.


            People

            • Assignee:
              Unassigned
              Reporter:
              Todd Lipcon
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development