Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.20.1
    • Fix Version/s: None
    • Component/s: tasktracker
    • Labels:

      Description

      In TaskTracker.java on create connection to JobTracker we check compare build version

      if(!VersionInfo.getBuildVersion().equals(jobTrackerBV))

      but

      public static String getBuildVersion()

      { return VersionInfo.getVersion() + " from " + VersionInfo.getRevision() + " by " + VersionInfo.getUser() + " source checksum " + VersionInfo.getSrcChecksum(); }

      in result identical version/revision/srcChecksum but compiled different users incompatible

        Activity

        Allen Wittenauer added a comment -

        I think this is "by design"...

        Alexey Diomin added a comment -

        we have error when build cluster with mixed distr (debian, centos).
        source build by different users in result cluster not started

        may be more correctly compare (version && revision && srcChecksum), not a build version string?

        Allen Wittenauer added a comment -

        This was essentially resolved with the move to Protobuf for the RPC layer.


          People

          • Assignee:
            Unassigned
            Reporter:
            Alexey Diomin
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development