Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.22.0
    • Fix Version/s: None
    • Component/s: build
    • Labels:
      None

      Description

      Findbugs reports 13 warnings on trunk:

      Warning Type Number
      Bad practice Warnings 1
      Correctness Warnings 5
      Multithreaded correctness Warnings 6
      Performance Warnings 1
      Total 13

        Activity

        Eli Collins created issue -
        Eli Collins added a comment -

        Full html report attached.

        Eli Collins made changes -
        Field Original Value New Value
        Attachment hadoop-findbugs-report.html [ 12459825 ]
        Nigel Daley added a comment -

        The patch that fixes these should also decrement the OK_FINDBUGS_WARNINGS property in src/test/test-patch.properties (hopefully to 0).

        Arun C Murthy added a comment -

        Duplicate of MAPREDUCE-2193 (which has a patch, albeit stale).

        Arun C Murthy made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Harsh J added a comment -

        Yup I was targeting at 0.22. The trunk refactoring has taken it outta shape. Will renew on MAPREDUCE-2193 shortly, but looks like findbugs reports need some work locally first, doing that


          People

          • Assignee:
            Unassigned
            Reporter:
            Eli Collins
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development