Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-2172

test-patch.properties contains incorrect/version-dependent values of OK_FINDBUGS_WARNINGS and OK_RELEASEAUDIT_WARNINGS

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.23.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      FindBugs 1.3.4

      Description

      Running ant test-patch with an empty patch yields 25 findbugs warning and 3 release audit warnings (rather than the 0 findbugs warnings and 1 release audit warning specified in test-patch.properties):

      [exec] -1 overall.  
      [exec] 
      [exec]     +1 @author.  The patch does not contain any @author tags.
      [exec] 
      [exec]     -1 tests included.  The patch doesn't appear to include any new or modified tests.
      [exec]                         Please justify why no new tests are needed for this patch.
      [exec]                         Also please list what manual steps were performed to verify this patch.
      [exec] 
      [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
      [exec] 
      [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
      [exec] 
      [exec]     -1 findbugs.  The patch appears to introduce 25 new Findbugs warnings.
      [exec] 
      [exec]     -1 release audit.  The applied patch generated 3 release audit warnings (more than the trunk's current 1 warnings).
      [exec] 
      [exec]     +1 system test framework.  The patch passed system test framework compile.
      

        Activity

        Ramkumar Vadali added a comment -

        @Nigel, both Patrick and I see ant test-patch fail on a clean checkout. We think this is related to HADOOP-7008. Is there some configuration we should change before running ant test-patch?

        Nigel Daley added a comment -

        Giri and I worked on getting Common pre-commit testing back in shape and that is now working (as of last night). I suspect MR trunk has drifted from clean javadoc, findbugs, and release audit warnings since it's MR pre-commit testing was working. We'll move on to cleaning this and HDFS up soon.

        Patrick Kling added a comment -

        The same issue exists in hadoop-common, where test-patch on a clean checkout yields 2 new findbugs warnings.

        Patrick Kling added a comment -

        I think part of the problem is that the exact number of warnings depends on the version of findbugs used. Is there a specific version that every developer should be using?

        Todd Lipcon added a comment -

        Same is true on HDFS - empty patches still claim lots of "new" release audit warnings.

        it looks like the test-patch script and the properties file are both 'externaled' in via SVN. but the properties file is obviously project-specific information. Can we just use externals for the script itself and check the properties file into each project separately?

        Nigel Daley added a comment -

        This adds the necessary base levels of release audit and findbug warnings. With an empty patch on trunk, I'm currentlyl seeing 13 findbugs warnings (I'll file an issue to fix these) and 2 release audit warnings that are ok.

        Nigel Daley added a comment -

        I just committed this. If you continue to experience problems with test-patch target, please open a new Jira and assign to me.

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #554 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/554/)

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #643 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-trunk/643/)


          People

          • Assignee:
            Nigel Daley
            Reporter:
            Patrick Kling
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development