Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-2164

MapredTestDriver.java compilation fails on trunk

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.22.0
    • Fix Version/s: None
    • Component/s: test
    • Labels:
      None

      Description

      compile-mapred-test:
      [mkdir] Created dir: /grid/0/hudson/hudson-slave/workspace/Hadoop-Mapreduce-trunk-Commit/trunk/build/test/mapred/classes
      [mkdir] Created dir: /grid/0/hudson/hudson-slave/workspace/Hadoop-Mapreduce-trunk-Commit/trunk/build/test/mapred/testjar
      [mkdir] Created dir: /grid/0/hudson/hudson-slave/workspace/Hadoop-Mapreduce-trunk-Commit/trunk/build/test/mapred/testshell
      [javac] Compiling 319 source files to /grid/0/hudson/hudson-slave/workspace/Hadoop-Mapreduce-trunk-Commit/trunk/build/test/mapred/classes
      [javac] /grid/0/hudson/hudson-slave/workspace/Hadoop-Mapreduce-trunk-Commit/trunk/src/test/mapred/org/apache/hadoop/test/MapredTestDriver.java:21: cannot find symbol
      [javac] symbol : class TestSequenceFile
      [javac] location: package org.apache.hadoop.io
      [javac] import org.apache.hadoop.io.TestSequenceFile;
      [javac] ^
      [javac] /grid/0/hudson/hudson-slave/workspace/Hadoop-Mapreduce-trunk-Commit/trunk/src/test/mapred/org/apache/hadoop/test/MapredTestDriver.java:59: cannot find symbol
      [javac] symbol : class TestSequenceFile
      [javac] location: class org.apache.hadoop.test.MapredTestDriver
      [javac] pgd.addClass("testsequencefile", TestSequenceFile.class,
      [javac] ^
      [javac] Note: Some input files use or override a deprecated API.
      [javac] Note: Recompile with -Xlint:deprecation for details.
      [javac] 2 errors

        Activity

        Owen O'Malley added a comment -

        It compiles for me at this point. If it still fails for you, please reopen.

        Owen O'Malley added a comment -

        I believe this to be a transient issue, since I moved that class from mapred to common. The next Hudson build should have it in common-test.


          People

          • Assignee:
            Unassigned
            Reporter:
            Giridharan Kesavan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development