Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.21.0
    • Fix Version/s: None
    • Component/s: build
    • Labels:
      None

      Description

      Similar to HDFS-1177 Ivy needs to be upgraded up to 2.1

      1. mapreduce-1830.patch
        0.3 kB
        Konstantin Boudnik

        Issue Links

          Activity

          Konstantin Boudnik made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Konstantin Boudnik added a comment -

          Fixed already as a part of MAPREDUCE-1870

          Tom White made changes -
          Fix Version/s 0.21.0 [ 12314045 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12446036/mapreduce-1830.patch
          against trunk revision 950286.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed core unit tests.

          -1 contrib tests. The patch failed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/219/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/219/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/219/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/219/console

          This message is automatically generated.

          Konstantin Boudnik made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Konstantin Boudnik added a comment -

          once more.

          Konstantin Boudnik made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Konstantin Boudnik added a comment -

          I'm seeing a bunch of NoClassDefFoundError issues unreproducible in the local runs where pull of latest versions of the Common's artifacts is happening as expected. Looks like a temp. glitch with Ivy or Maven repo. Will resubmit the patch once more.

          Apparently no test can be provided for the patch. The only verification is the build and tests execution.

          Konstantin Boudnik made changes -
          Link This issue is related to HADOOP-6798 [ HADOOP-6798 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12446036/mapreduce-1830.patch
          against trunk revision 950021.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed core unit tests.

          -1 contrib tests. The patch failed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/218/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/218/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/218/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/218/console

          This message is automatically generated.

          Konstantin Boudnik made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Assignee Konstantin Boudnik [ cos ]
          Fix Version/s 0.21.0 [ 12314045 ]
          Konstantin Boudnik made changes -
          Field Original Value New Value
          Attachment mapreduce-1830.patch [ 12446036 ]
          Konstantin Boudnik added a comment -

          Fix for the version upgrade.

          Konstantin Boudnik created issue -

            People

            • Assignee:
              Konstantin Boudnik
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development