Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1756

FairScheduler may assign tasks over the TaskTracker limit

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.22.0
    • Component/s: contrib/fair-share
    • Labels:
      None

      Description

      FairScheduler may assign tasks over the TaskTracker limit.
      The over assigned task will wait on the TaskTracker in the state of UNASSIGNED causing a higher latency.

        Activity

        Scott Chen added a comment -

        Sorry, I made a mistake.
        CapBasedLoadManager.canAssign

        {Map,Reduce}

        () will prevent this from happening.
        The problem is not valid.


          People

          • Assignee:
            Scott Chen
            Reporter:
            Scott Chen
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development