Code looks good. Some comments.
1) Check if all import statements make sense . - NetworkedJob is not required. Check for all imports.
2) There should be space between parameters in methods like in this : UtilsForSystemTests.restartCluster(cluster,prop); Check this for throughout testcase.
3) resetClusterWithNewConfigMapred seems a better name than resetCluster, becuse users can understand the intent of this feature just by reading the name rather than seeing the javadocs. The same goes with resetCluster. It can be resetClusterWithOldConfig.
4) All input, output directory creation and deletion should be done in BeforeClass and AfterClass. This to avoid testcase assuming that a directory is already present. and a testacse cleaning up all directories it created before exiting, even if it failed inteh middle.
5) if (!tttInfo.isTaskCleanupTask()) - Even setup task could be checked to avoid it and made fully sure its only mapper.