Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.22.0
    • Fix Version/s: None
    • Component/s: test
    • Labels:
      None

      Description

      TestMiniMRLocalFS fails consistently on trunk:

      Testcase: testWithLocal took 38.957 sec
              Caused an ERROR
      File QuasiMonteCarlo_TMP_3_141592654/out/reduce-out does not exist.
      java.io.FileNotFoundException: File QuasiMonteCarlo_TMP_3_141592654/out/reduce-out does not exist.
              at org.apache.hadoop.fs.RawLocalFileSystem.getFileStatus(RawLocalFileSystem.java:420)
              at org.apache.hadoop.fs.FilterFileSystem.getFileStatus(FilterFileSystem.java:246)
              at org.apache.hadoop.io.SequenceFile$Reader.<init>(SequenceFile.java:1466)
              at org.apache.hadoop.io.SequenceFile$Reader.<init>(SequenceFile.java:1447)
              at org.apache.hadoop.examples.QuasiMonteCarlo.estimatePi(QuasiMonteCarlo.java:313)
              at org.apache.hadoop.mapred.TestMiniMRWithDFS.runPI(TestMiniMRWithDFS.java:235)
              at org.apache.hadoop.mapred.TestMiniMRLocalFS.testWithLocal(TestMiniMRLocalFS.java:68)
      

        Activity

        Hemanth Yamijala added a comment -

        This is a duplicate of MAPREDUCE-1520. There's a patch on it with a +1 from Devaraj. Can it be committed ?


          People

          • Assignee:
            Unassigned
            Reporter:
            Chris Douglas
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development