Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1280

Eclipse Plugin does not work with Eclipse Ganymede (3.4)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.20.1, 0.21.1, 0.22.0
    • Fix Version/s: 0.20.3, 0.20.203.0, 0.21.1, 0.22.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows XP with Eclipse "Ganymede" 3.4

    • Hadoop Flags:
      Reviewed

      Description

      The newest version of Eclipse seems incompatible with the plugin. The plugin as released in 0.16.4 will allow you to add/remove MapReduce servers, and will allow you to browse/manipulate the DFS in the DFS Browser, but will not allow you to run programs. Clicking "Run As * Run On Hadoop" will simply not cause the run-on-hadoop server selection window to appear. No error message is given.

      Dropping the 0.17.1 copy of the plugin JAR into the eclipse/plugins/ directory does not fix the issue; it is in fact worse: Eclipse does not seem to regard the 0.17 plugin as real. No "MapReduce Perspective" is made available in the perspectives selection window.

      1. hadoop-eclipse-plugin-0.20.3-SNAPSHOT.jar
        2.77 MB
        Helmut Zechmann
      2. HadoopApplicationLaunchShortcut.diff
        1 kB
        Tvrtko Bedekovic
      3. HADOOP-3744.patch
        2 kB
        Doug Cutting
      4. alex-HADOOP-3744.patch
        2 kB
        Alex Kozlov

        Issue Links

          Activity

          Hide
          Christophe Taton added a comment -

          Hi Aaron,
          I tried running the 0.17.1 plugin jar out of the box and on Eclipse 3.4 (on Linux), and the plugin is effectively recognized in my case and shows the Map/Reduce perspective correctly; however, as you point out, the "Run on Hadoop" shortcut fails silently in this configuration.
          I have still not found out the origin of this problem.
          Could you double check that 0.17.1 is not recognized at all on your install, as it is at least recognized on mine.
          I'm actually cleaning and updating the plug-in, but I admit my thesis does not allow me to spend as much time as I would like to on this...
          Cheers

          Show
          Christophe Taton added a comment - Hi Aaron, I tried running the 0.17.1 plugin jar out of the box and on Eclipse 3.4 (on Linux), and the plugin is effectively recognized in my case and shows the Map/Reduce perspective correctly; however, as you point out, the "Run on Hadoop" shortcut fails silently in this configuration. I have still not found out the origin of this problem. Could you double check that 0.17.1 is not recognized at all on your install, as it is at least recognized on mine. I'm actually cleaning and updating the plug-in, but I admit my thesis does not allow me to spend as much time as I would like to on this... Cheers
          Hide
          Aaron Kimball added a comment - - edited

          I just performed the following steps on my Windows XP machine:

          1) Removed hadoop-0.16.4-eclipse-plugin.jar from eclipse/plugins/
          2) Copied hadoop-0.17.1-eclipse-plugin.jar from a clean unzip of hadoop-0.17.1.tar.gz into that directory.
          3) Start Eclipse Ganymede. When prompted for a workspace, I chose a new empty directory
          4) Go to the workbench and "Open Perspective". MapReduce is missing from the list. Furthermore, Help * About * Plugin Details does not list the Hadoop plugin in its list.

          That having been said, under "Configuration details," under "Configured plugins," it does list:
          file:/C:/home/aaron/Desktop/eclipse-ganymede/plugins/hadoop-0.17.1-eclipse-plugin.jar

          Show
          Aaron Kimball added a comment - - edited I just performed the following steps on my Windows XP machine: 1) Removed hadoop-0.16.4-eclipse-plugin.jar from eclipse/plugins/ 2) Copied hadoop-0.17.1-eclipse-plugin.jar from a clean unzip of hadoop-0.17.1.tar.gz into that directory. 3) Start Eclipse Ganymede. When prompted for a workspace, I chose a new empty directory 4) Go to the workbench and "Open Perspective". MapReduce is missing from the list. Furthermore, Help * About * Plugin Details does not list the Hadoop plugin in its list. That having been said, under "Configuration details," under "Configured plugins," it does list: file:/C:/home/aaron/Desktop/eclipse-ganymede/plugins/hadoop-0.17.1-eclipse-plugin.jar
          Hide
          Doug Cutting added a comment -

          I'm trying to build a 0.18.0 release using Eclipse 3.2, and the Eclipse build is failing because the signature of org.eclipse.core.runtime.Status has changed. Could this be the same problem?

          I've attached a quick hack that makes things compile, but, as a non-eclipse user, I have no idea if they actually run.

          Show
          Doug Cutting added a comment - I'm trying to build a 0.18.0 release using Eclipse 3.2, and the Eclipse build is failing because the signature of org.eclipse.core.runtime.Status has changed. Could this be the same problem? I've attached a quick hack that makes things compile, but, as a non-eclipse user, I have no idea if they actually run.
          Hide
          Dave Latham added a comment - - edited

          I can verify Aaron's account - I see the same thing. The plugin shows up under the configuration details (but not plug-in) details, nor is the perspective available. Eclipse Ganymede (3.4) hadoop plugin 0.17.1.

          Show
          Dave Latham added a comment - - edited I can verify Aaron's account - I see the same thing. The plugin shows up under the configuration details (but not plug-in) details, nor is the perspective available. Eclipse Ganymede (3.4) hadoop plugin 0.17.1.
          Hide
          Aaron Kimball added a comment -

          To follow up: Using v0.18.0 with Doug's patch from https://issues.apache.org/jira/browse/HADOOP-3884, it seems like we're now back to the 0.16.4 state. Plugin is "real" and can see the DFS, etc., but the run dialog still doesn't show up.

          Show
          Aaron Kimball added a comment - To follow up: Using v0.18.0 with Doug's patch from https://issues.apache.org/jira/browse/HADOOP-3884 , it seems like we're now back to the 0.16.4 state. Plugin is "real" and can see the DFS, etc., but the run dialog still doesn't show up.
          Hide
          Tsz Wo Nicholas Sze added a comment -

          Eclipse plugin also has some problem in Windows, see HADOOP-4310.

          Show
          Tsz Wo Nicholas Sze added a comment - Eclipse plugin also has some problem in Windows, see HADOOP-4310 .
          Hide
          Tvrtko Bedekovic added a comment -

          I've sent an email to Christophe Taton but got no reply so I'm posting here.

          I'm attaching a diff of HadoopApplicationLaunchShortcut.java with 2 lines that need to be changed/added so that the plugin builds and works correctly for Eclipse 3.4 Ganymede.

          Show
          Tvrtko Bedekovic added a comment - I've sent an email to Christophe Taton but got no reply so I'm posting here. I'm attaching a diff of HadoopApplicationLaunchShortcut.java with 2 lines that need to be changed/added so that the plugin builds and works correctly for Eclipse 3.4 Ganymede.
          Hide
          Greg Bayer added a comment -

          Applying HadoopApplicationLaunchShortcut.diff and rebuilding the plugin works well. I am using the plugin daily with Eclipse 3.4.

          As of last week at Hadoop Summit '09, there are still many people under the impression that the Hadoop Eclipse plugin is broken. Is there any reason this fix hasn't been rolled into recent Hadoop releases and announced more publicly?

          Show
          Greg Bayer added a comment - Applying HadoopApplicationLaunchShortcut.diff and rebuilding the plugin works well. I am using the plugin daily with Eclipse 3.4. As of last week at Hadoop Summit '09, there are still many people under the impression that the Hadoop Eclipse plugin is broken. Is there any reason this fix hasn't been rolled into recent Hadoop releases and announced more publicly?
          Hide
          stephen mulcahy added a comment -

          I ran into the same problem with Eclipse 3.4 on Debian Linux 5.0 - I could browse DFS with the eclipse plugin from hadoop 0.19.2 but I couldn't run a Hadoop Job.

          I checked out http://svn.apache.org/repos/asf/hadoop/common/tags/release-0.19.2/ and rebuilt the plugin against my local eclipse as follows,

          ant -Declipse.home=/usr/local/eclipse clean package

          and copied the resulting plugin .jar file to /usr/local/eclipse/plugins.

          For some reason the MapReduce perspective was no longer available and I couldn't see any error from Eclipse. I figure maybe moving from one version of the plugin to another might have corrupted something in Eclipse?

          Anyways - since I was at it, I tried installing the latest Eclipse (3.5, Galileo) and rebuilt the plugin against this version. I then installed it as above and start Eclipse.

          This time the plugin works perfectly - I can both browse DFS and run a job against Hadoop. So, in conclusion, the patch works against Eclipse 3.5 (on Linux at least) also.

          +1 on including this in the release.

          Show
          stephen mulcahy added a comment - I ran into the same problem with Eclipse 3.4 on Debian Linux 5.0 - I could browse DFS with the eclipse plugin from hadoop 0.19.2 but I couldn't run a Hadoop Job. I checked out http://svn.apache.org/repos/asf/hadoop/common/tags/release-0.19.2/ and rebuilt the plugin against my local eclipse as follows, ant -Declipse.home=/usr/local/eclipse clean package and copied the resulting plugin .jar file to /usr/local/eclipse/plugins. For some reason the MapReduce perspective was no longer available and I couldn't see any error from Eclipse. I figure maybe moving from one version of the plugin to another might have corrupted something in Eclipse? Anyways - since I was at it, I tried installing the latest Eclipse (3.5, Galileo) and rebuilt the plugin against this version. I then installed it as above and start Eclipse. This time the plugin works perfectly - I can both browse DFS and run a job against Hadoop. So, in conclusion, the patch works against Eclipse 3.5 (on Linux at least) also. +1 on including this in the release.
          Hide
          stephen mulcahy added a comment -

          Added 0.19.2 to list of affected versions

          Show
          stephen mulcahy added a comment - Added 0.19.2 to list of affected versions
          Hide
          Alex Kozlov added a comment -

          I am attaching a patch that fixes a few issues with the Hadoop Eclipse plugin in Galileo and Hadoop 0.20 and later versions:

          • Compilation error with the new eclipse plugin libraries
          • Warning about hadoop-site.xml
          • Not being able to run the job in Hadoop
            Tested with 0.20, 0.21, and 0.22

            Alex Kozlov
          Show
          Alex Kozlov added a comment - I am attaching a patch that fixes a few issues with the Hadoop Eclipse plugin in Galileo and Hadoop 0.20 and later versions: Compilation error with the new eclipse plugin libraries Warning about hadoop-site.xml Not being able to run the job in Hadoop Tested with 0.20, 0.21, and 0.22 – Alex Kozlov
          Hide
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12427395/alex-HADOOP-3744.patch
          against trunk revision 888565.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          -1 patch. The patch command could not apply the patch.

          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/178/console

          This message is automatically generated.

          Show
          Hadoop QA added a comment - -1 overall. Here are the results of testing the latest attachment http://issues.apache.org/jira/secure/attachment/12427395/alex-HADOOP-3744.patch against trunk revision 888565. +1 @author. The patch does not contain any @author tags. -1 tests included. The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch. -1 patch. The patch command could not apply the patch. Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/178/console This message is automatically generated.
          Hide
          Alex Kozlov added a comment -

          I notices another issue with the plugin: the plugin generates Hadoop config data in Workspace/.metadata/.plugins/org.apache.hadoop.eclipse directory, which does not seem to be cleaned.

          Show
          Alex Kozlov added a comment - I notices another issue with the plugin: the plugin generates Hadoop config data in Workspace/.metadata/.plugins/org.apache.hadoop.eclipse directory, which does not seem to be cleaned.
          Hide
          Chris Douglas added a comment -

          Moved to the MapReduce project, where the eclipse plugin is

          Show
          Chris Douglas added a comment - Moved to the MapReduce project, where the eclipse plugin is
          Hide
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12427395/alex-HADOOP-3744.patch
          against trunk revision 888761.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          -1 javac. The patch appears to cause tar ant target to fail.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          -1 contrib tests. The patch failed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/310/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/310/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/310/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/310/console

          This message is automatically generated.

          Show
          Hadoop QA added a comment - -1 overall. Here are the results of testing the latest attachment http://issues.apache.org/jira/secure/attachment/12427395/alex-HADOOP-3744.patch against trunk revision 888761. +1 @author. The patch does not contain any @author tags. -1 tests included. The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch. +1 javadoc. The javadoc tool did not generate any warning messages. -1 javac. The patch appears to cause tar ant target to fail. +1 findbugs. The patch does not introduce any new Findbugs warnings. +1 release audit. The applied patch does not increase the total number of release audit warnings. +1 core tests. The patch passed core unit tests. -1 contrib tests. The patch failed contrib unit tests. Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/310/testReport/ Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/310/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/310/artifact/trunk/build/test/checkstyle-errors.html Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/310/console This message is automatically generated.
          Hide
          Chris Douglas added a comment -

          Cancelling until MAPREDUCE-1299 is resolved.

          Would committer who uses eclipse please monitor these issues?

          Show
          Chris Douglas added a comment - Cancelling until MAPREDUCE-1299 is resolved. Would committer who uses eclipse please monitor these issues?
          Hide
          Eli Collins added a comment -

          Re-submitting, looks like Hudson was updated for MAPREDUCE-1299.

          Show
          Eli Collins added a comment - Re-submitting, looks like Hudson was updated for MAPREDUCE-1299 .
          Hide
          Eli Collins added a comment -

          +1 to alex-HADOOP-3744.patch.

          I verified that it fixes the compilation issue with galileo.

          Show
          Eli Collins added a comment - +1 to alex- HADOOP-3744 .patch. I verified that it fixes the compilation issue with galileo.
          Hide
          Tsz Wo Nicholas Sze added a comment -

          Hi Eli, how did you verify it? Does it work with Helios? I would like to know more about the Eclipse plug-in.

          Show
          Tsz Wo Nicholas Sze added a comment - Hi Eli, how did you verify it? Does it work with Helios? I would like to know more about the Eclipse plug-in.
          Hide
          Eli Collins added a comment -

          Project -> Build Project in eclipse compiles the eclipse plugin. Verified this on galileo, I also checked helios and that compiles as well. The issue is that the eclipse plugin uses classes that were deprecated in 3.1, and were removed I think in 3.4 so you'll get the following:

          compile:
                  [echo] contrib: eclipse-plugin
                 [javac] Compiling 45 source files to /home/eli/src/cloudera/hadoop1/build/contrib/eclipse-plugin/classes
                 [javac] /home/eli/src/cloudera/hadoop1/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/launch/HadoopApplicationLaunchShortcut.java:35: cannot find symbol
                 [javac] symbol  : class JavaApplicationLaunchShortcut
                 [javac] location: package org.eclipse.jdt.internal.debug.ui.launcher
                 [javac] import org.eclipse.jdt.internal.debug.ui.launcher.JavaApplicationLaunchShortcut;
                 [javac]                                                  ^
                 [javac] /home/eli/src/cloudera/hadoop1/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/launch/HadoopApplicationLaunchShortcut.java:49: cannot find symbol
                 [javac] symbol: class JavaApplicationLaunchShortcut
                 [javac]     JavaApplicationLaunchShortcut {
                 [javac]     ^
                 [javac] /home/eli/src/cloudera/hadoop1/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/launch/HadoopApplicationLaunchShortcut.java:66: cannot find symbol
                 [javac] symbol  : variable super
                 [javac] location: class org.apache.hadoop.eclipse.launch.HadoopApplicationLaunchShortcut
                 [javac]         super.findLaunchConfiguration(type, configType);
                 [javac]         ^
                 [javac] /home/eli/src/cloudera/hadoop1/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/launch/HadoopApplicationLaunchShortcut.java:60: method does not override or implement a method from a supertype
                 [javac]   @Override
                 [javac]   ^
                 [javac] Note: Some input files use or override a deprecated API.
                 [javac] Note: Recompile with -Xlint:deprecation for details.
                 [javac] Note: Some input files use unchecked or unsafe operations.
                 [javac] Note: Recompile with -Xlint:unchecked for details.
                 [javac] 4 errors
          
          Show
          Eli Collins added a comment - Project -> Build Project in eclipse compiles the eclipse plugin. Verified this on galileo, I also checked helios and that compiles as well. The issue is that the eclipse plugin uses classes that were deprecated in 3.1, and were removed I think in 3.4 so you'll get the following: compile: [echo] contrib: eclipse-plugin [javac] Compiling 45 source files to /home/eli/src/cloudera/hadoop1/build/contrib/eclipse-plugin/classes [javac] /home/eli/src/cloudera/hadoop1/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/launch/HadoopApplicationLaunchShortcut.java:35: cannot find symbol [javac] symbol : class JavaApplicationLaunchShortcut [javac] location: package org.eclipse.jdt.internal.debug.ui.launcher [javac] import org.eclipse.jdt.internal.debug.ui.launcher.JavaApplicationLaunchShortcut; [javac] ^ [javac] /home/eli/src/cloudera/hadoop1/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/launch/HadoopApplicationLaunchShortcut.java:49: cannot find symbol [javac] symbol: class JavaApplicationLaunchShortcut [javac] JavaApplicationLaunchShortcut { [javac] ^ [javac] /home/eli/src/cloudera/hadoop1/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/launch/HadoopApplicationLaunchShortcut.java:66: cannot find symbol [javac] symbol : variable super [javac] location: class org.apache.hadoop.eclipse.launch.HadoopApplicationLaunchShortcut [javac] super .findLaunchConfiguration(type, configType); [javac] ^ [javac] /home/eli/src/cloudera/hadoop1/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/launch/HadoopApplicationLaunchShortcut.java:60: method does not override or implement a method from a supertype [javac] @Override [javac] ^ [javac] Note: Some input files use or override a deprecated API. [javac] Note: Recompile with -Xlint:deprecation for details. [javac] Note: Some input files use unchecked or unsafe operations. [javac] Note: Recompile with -Xlint:unchecked for details. [javac] 4 errors
          Hide
          Tsz Wo Nicholas Sze added a comment -

          Thanks Alex and Eli. Let try re-submitting it.

          Show
          Tsz Wo Nicholas Sze added a comment - Thanks Alex and Eli. Let try re-submitting it.
          Hide
          Eli Collins added a comment -

          Kicking hudson.

          Show
          Eli Collins added a comment - Kicking hudson.
          Hide
          Tsz Wo Nicholas Sze added a comment -

          BTW, do we have documentation about the Eclipse plug-in?

          Show
          Tsz Wo Nicholas Sze added a comment - BTW, do we have documentation about the Eclipse plug-in?
          Hide
          Eli Collins added a comment -
          Show
          Eli Collins added a comment - First hit on google - http://wiki.apache.org/hadoop/EclipsePlugIn
          Hide
          Eli Collins added a comment -

          test-patch results:

               [exec] 
               [exec] -1 overall.  
               [exec] 
               [exec]     +1 @author.  The patch does not contain any @author tags.
               [exec] 
               [exec]     -1 tests included.  The patch doesn't appear to include any new or modified tests.
               [exec]                         Please justify why no new tests are needed for this patch.
               [exec]                         Also please list what manual steps were performed to verify this patch.
               [exec] 
               [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
               [exec] 
               [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
               [exec] 
               [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
               [exec] 
               [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
               [exec] 
               [exec]     +1 system tests framework.  The patch passed system tests framework compile.
               [exec] 
          
          Show
          Eli Collins added a comment - test-patch results: [exec] [exec] -1 overall. [exec] [exec] +1 @author. The patch does not contain any @author tags. [exec] [exec] -1 tests included. The patch doesn't appear to include any new or modified tests. [exec] Please justify why no new tests are needed for this patch. [exec] Also please list what manual steps were performed to verify this patch. [exec] [exec] +1 javadoc. The javadoc tool did not generate any warning messages. [exec] [exec] +1 javac. The applied patch does not increase the total number of javac compiler warnings. [exec] [exec] +1 findbugs. The patch does not introduce any new Findbugs warnings. [exec] [exec] +1 release audit. The applied patch does not increase the total number of release audit warnings. [exec] [exec] +1 system tests framework. The patch passed system tests framework compile. [exec]
          Hide
          Tsz Wo Nicholas Sze added a comment -

          I was going to commit this. Which versions should this be committed? 0.20, 0.21 and trunk?

          Show
          Tsz Wo Nicholas Sze added a comment - I was going to commit this. Which versions should this be committed? 0.20, 0.21 and trunk?
          Hide
          Eli Collins added a comment -

          Thanks Nicholas! Yes, 20, 21 and trunk.

          Show
          Eli Collins added a comment - Thanks Nicholas! Yes, 20, 21 and trunk.
          Hide
          Tsz Wo Nicholas Sze added a comment -
               [exec]     -1 tests included.  The patch doesn't appear to include any new or modified tests.
               [exec]                         Please justify why no new tests are needed for this patch.
          

          We don't have unit tests for eclipse plugin. The patch was tested manually by Alex and Eli.

          I have committed this to 0.20, 0.20-append, 0.21 and trunk. Thanks Alex!

          Also thanks Eli for reviewing and testing it.

          Show
          Tsz Wo Nicholas Sze added a comment - [exec] -1 tests included. The patch doesn't appear to include any new or modified tests. [exec] Please justify why no new tests are needed for this patch. We don't have unit tests for eclipse plugin. The patch was tested manually by Alex and Eli. I have committed this to 0.20, 0.20-append, 0.21 and trunk. Thanks Alex! Also thanks Eli for reviewing and testing it.
          Hide
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #523 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/523/)

          Show
          Hudson added a comment - Integrated in Hadoop-Mapreduce-trunk-Commit #523 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/523/ )
          Hide
          Helmut Zechmann added a comment -

          The file hadoop-eclipse-plugin-0.20.3-SNAPSHOT.jar contains the patch submitted in this ticket. I tested it sucessfully on Mac OX 10.6 using hadoop 0.20.2 and eclipse 3.5.2 (Galileo) as well as eclipse 3.6.1 (Helios).
          To use this plugin, simply remove older versions of the plugin and put the attached file into the "dropins"-folder.
          After upgrading to this plugin you will need to start eclipse with the "-clean" command line switch.

          Show
          Helmut Zechmann added a comment - The file hadoop-eclipse-plugin-0.20.3-SNAPSHOT.jar contains the patch submitted in this ticket. I tested it sucessfully on Mac OX 10.6 using hadoop 0.20.2 and eclipse 3.5.2 (Galileo) as well as eclipse 3.6.1 (Helios). To use this plugin, simply remove older versions of the plugin and put the attached file into the "dropins"-folder. After upgrading to this plugin you will need to start eclipse with the "-clean" command line switch.
          Hide
          Paulo Henrique Ramos added a comment -

          Good evening,

          My name is Paul, I'm having trouble on the set of the Eclipse environment. After inserting the hadoop plugins folder of Eclipse plugins, so after inserting plugin, I follow the step by step taught in the site, however, do not get success because it appears in the directory the following error ... Error: null

          Sincerely,
          Paulo Ramos

          Show
          Paulo Henrique Ramos added a comment - Good evening, My name is Paul, I'm having trouble on the set of the Eclipse environment. After inserting the hadoop plugins folder of Eclipse plugins, so after inserting plugin, I follow the step by step taught in the site, however, do not get success because it appears in the directory the following error ... Error: null Sincerely, Paulo Ramos
          Hide
          Owen O'Malley added a comment -

          Closing for 0.20.203.0

          Show
          Owen O'Malley added a comment - Closing for 0.20.203.0
          Hide
          sadanand added a comment -

          Does it work from windows environment?

          Show
          sadanand added a comment - Does it work from windows environment?
          Hide
          sadanand added a comment -

          Hello, i'm having trouble on setting eclipse for our cluster from my linux box.it's throwing following error

          Cannot connect to the Map/Reduce location: mapreduce
          Call to hadoop05.cloud.com/192.168.1.12:8021 failed on local exception: java.io.EOFException

          i am using eclipse 3.5 and CDH3 distribution.

          Thanks

          Show
          sadanand added a comment - Hello, i'm having trouble on setting eclipse for our cluster from my linux box.it's throwing following error Cannot connect to the Map/Reduce location: mapreduce Call to hadoop05.cloud.com/192.168.1.12:8021 failed on local exception: java.io.EOFException i am using eclipse 3.5 and CDH3 distribution. Thanks
          Hide
          Michael Aro added a comment -

          Improving the Eclipse Plugin "http://wiki.apache.org/hadoop/ProjectSuggestions". What is the latest status and the next steps in case improvement is needed still?

          Show
          Michael Aro added a comment - Improving the Eclipse Plugin "http://wiki.apache.org/hadoop/ProjectSuggestions". What is the latest status and the next steps in case improvement is needed still?
          Hide
          Austin wei added a comment -

          Is there any eclipse plugin work for hadoop0.20.205.0, i'm working on windows environment and the version of eclipse is 3.7.1 ,after install the default plugin of hadoop0.20.205.0 ,eclipse got an error " error:failure to login" when connect to hadoop. I've found a issue similar to my question.

          http://lucene.472066.n3.nabble.com/Help-with-Hadoop-Eclipse-Plugin-on-Mac-OS-X-Lion-tt3554041.html#a3561596

          Show
          Austin wei added a comment - Is there any eclipse plugin work for hadoop0.20.205.0, i'm working on windows environment and the version of eclipse is 3.7.1 ,after install the default plugin of hadoop0.20.205.0 ,eclipse got an error " error:failure to login" when connect to hadoop. I've found a issue similar to my question. http://lucene.472066.n3.nabble.com/Help-with-Hadoop-Eclipse-Plugin-on-Mac-OS-X-Lion-tt3554041.html#a3561596

            People

            • Assignee:
              Alex Kozlov
              Reporter:
              Aaron Kimball
            • Votes:
              10 Vote for this issue
              Watchers:
              19 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development