Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.22.0
    • Fix Version/s: None
    • Component/s: contrib/streaming
    • Labels:
      None

      Description

      Compile fails. It seems that hdfs-test jar file cannot be found.
      compile-test:
      [echo] contrib: streaming
      [javac] Compiling 44 source files to /home/schen/asf-mapred2/build/contrib/streaming/test
      [javac] /home/schen/asf-mapred2/src/contrib/streaming/src/test/org/apache/hadoop/streaming/TestDumpTypedBytes.java:30: cannot find symbol
      [javac] symbol : class MiniDFSCluster
      [javac] location: package org.apache.hadoop.hdfs
      [javac] import org.apache.hadoop.hdfs.MiniDFSCluster;
      [javac] ^
      [javac] /home/schen/asf-mapred2/src/contrib/streaming/src/test/org/apache/hadoop/streaming/TestLoadTypedBytes.java:29: cannot find symbol
      [javac] symbol : class MiniDFSCluster
      [javac] location: package org.apache.hadoop.hdfs
      [javac] import org.apache.hadoop.hdfs.MiniDFSCluster;
      [javac] ^
      [javac] /home/schen/asf-mapred2/src/contrib/streaming/src/test/org/apache/hadoop/streaming/TestMultipleArchiveFiles.java:36: cannot find symbol
      [javac] symbol : class MiniDFSCluster
      [javac] location: package org.apache.hadoop.hdfs
      [javac] import org.apache.hadoop.hdfs.MiniDFSCluster;

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        1h 5m 1 Dmytro Molkov 26/Nov/09 00:13
        Patch Available Patch Available Resolved Resolved
        3h 21m 1 Vinod Kumar Vavilapalli 26/Nov/09 03:35
        Scott Chen added a comment -

        Sorry for the mistake. I should have found out MAPREDUCE-1239.
        Thanks for closing it down.

        Vinod Kumar Vavilapalli added a comment -

        Just as a note, I've closed this issue instead of MAPREDUCE-1239 because MAPREDUCE-1239 already seems to have a patch that addresses problems with all the contrib projects.

        Vinod Kumar Vavilapalli made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Vinod Kumar Vavilapalli added a comment -

        This is a duplicate of MAPREDUCE-1239.

        Scott Chen added a comment -

        same problem in contrib/capacity-scheduler

        Scott Chen added a comment -

        +1 the patch works.

        Dmytro Molkov made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Affects Version/s 0.22.0 [ 12314184 ]
        Dmytro Molkov added a comment -

        Please have a look at this.

        Dmytro Molkov made changes -
        Attachment MAPREDUCE-1243.patch [ 12426161 ]
        Dmytro Molkov added a comment -

        Adding a patch with additional dependancies for streaming.
        Ran the tests and those passed, so this should do it

        Scott Chen added a comment -

        contrib/streaming/ivy.xml does not cover some of the dependencies

        Scott Chen made changes -
        Field Original Value New Value
        Assignee Dmytro Molkov [ dms ]
        Scott Chen created issue -

          People

          • Assignee:
            Dmytro Molkov
            Reporter:
            Scott Chen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development