Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1003

trunk build fails when -Declipse.home is set

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      Minor changes to HadoopJob.java in eclipse-plugin contrib project to accommodate changes in JobStatus (MAPREDUCE-777)
      Show
      Minor changes to HadoopJob.java in eclipse-plugin contrib project to accommodate changes in JobStatus ( MAPREDUCE-777 )

      Description

      compile:
      [echo] contrib: eclipse-plugin
      [javac] Compiling 45 source files to /grid/0/hudson/hudson-slave/workspace/Mapreduce-Patch-h3.grid.sp2.yahoo.net/trunk/build/contrib/eclipse-plugin/classes
      [javac] /grid/0/hudson/hudson-slave/workspace/Mapreduce-Patch-h3.grid.sp2.yahoo.net/trunk/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/server/HadoopJob.java:54: constant expression required
      [javac] case JobStatus.PREP:
      [javac] ^
      [javac] /grid/0/hudson/hudson-slave/workspace/Mapreduce-Patch-h3.grid.sp2.yahoo.net/trunk/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/server/HadoopJob.java:56: constant expression required
      [javac] case JobStatus.RUNNING:
      [javac] ^
      [javac] /grid/0/hudson/hudson-slave/workspace/Mapreduce-Patch-h3.grid.sp2.yahoo.net/trunk/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/server/HadoopJob.java:58: constant expression required
      [javac] case JobStatus.FAILED:
      [javac] ^
      [javac] /grid/0/hudson/hudson-slave/workspace/Mapreduce-Patch-h3.grid.sp2.yahoo.net/trunk/src/contrib/eclipse-plugin/src/java/org/apache/hadoop/eclipse/server/HadoopJob.java:60: constant expression required
      [javac] case JobStatus.SUCCEEDED:
      [javac] ^
      [javac] Note: Some input files use or override a deprecated API.
      [javac] Note: Recompile with -Xlint:deprecation for details.
      [javac] Note: Some input files use unchecked or unsafe operations.
      [javac] Note: Recompile with -Xlint:unchecked for details.
      [javac] 4 errors

        Activity

        Hemanth Yamijala added a comment -

        Giri thinks this is caused by MAPREDUCE-777. Unfortunately, since this build does not run unless -Declipse.home is set, we did not catch it when running test and test-patch.

        Ravi Gummadi added a comment -

        Attaching patch fixing the issue.

        Hemanth Yamijala added a comment -

        Looks fine to me. Can you please upload test-patch results, so we can commit this and unblock Hudson. Since there are no tests for the eclipse plugin, I suppose we don't have to run tests.

        Ravi Gummadi added a comment -

        ant test-contrib passed.

        ant test-patch gave:

        [exec] -1 overall.
        [exec]
        [exec] +1 @author. The patch does not contain any @author tags.
        [exec]
        [exec] -1 tests included. The patch doesn't appear to include any new or modified tests.
        [exec] Please justify why no new tests are needed for this patch.
        [exec] Also please list what manual steps were performed to verify this patch.
        [exec]
        [exec] +1 javadoc. The javadoc tool did not generate any warning messages.
        [exec]
        [exec] +1 javac. The applied patch does not increase the total number of javac compiler warnings.
        [exec]
        [exec] +1 findbugs. The patch does not introduce any new Findbugs warnings.
        [exec]
        [exec] -1 release audit. The applied patch generated 177 release audit warnings (more than the trunk's current 0 warnings).

        The release audit warnings are not related to this patch. 177 release audit warnings are seen for other patches' test-patch results also.

        Hemanth Yamijala added a comment -

        I actually got better results with the same patch when I ran locally. Ravi, you possibly need to run ant clean on your workspace to remove the release audit warnings - that might come if you have documentation around.

             [exec] +1 overall.
             [exec]
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec]
             [exec]     -1 tests included.  The patch doesn't appear to include any new or modified tests.
             [exec]                         Please justify why no new tests are needed for this patch.
             [exec]                         Also please list what manual steps were performed to verify this patch.
             [exec]
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec]
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec]
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec]
             [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
             [exec]
        

        I am unaware what tests to run for the eclipse plugin. Taking an exception and committing so that hudson can get back to normal.

        Ravi Gummadi added a comment -

        WIth "ant clean" and then I also didnot get any releaseaudit warnings.

        Giridharan Kesavan added a comment -

        with ant -Declipse.home=<eclipsehome> build's successful.
        +1

        Hemanth Yamijala added a comment -

        I just committed this. Thanks, Ravi !

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #53 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/53/)
        . Fix compilation problem in eclipse plugin when eclipse.home is set. Contributed by Ravi Gummadi.

        Nigel Daley added a comment -

        Umm, the test-path DID find this. It was just ignored by the committer and contributor!


          People

          • Assignee:
            Ravi Gummadi
            Reporter:
            Giridharan Kesavan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development