Maven Antrun Plugin
  1. Maven Antrun Plugin
  2. MANTRUN-109

[regression] antrun execution dies silently

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.3
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Maven version: 2.0.10
      Java version: 1.5.0_16
      OS name: "mac os x" version: "10.5.6" arch: "i386" Family: "unix"

      Description

      The title says it all.

      Ive attached a log of running with -X -e

      1. MANTRUN-108.zip
        13 kB
        Martin West
      2. MANTRUN-108.zip
        0.2 kB
        Martin West
      3. mvn-2.0.10.log
        181 kB
        Martin West

        Activity

        Martin West added a comment -

        PS runs fine on 2.0.9

        Benjamin Bentmann added a comment -

        How about a minimal test project to help us reproduce the issue?

        Martin West added a comment -

        minimal project, well as minimal as I make it.

        You just need to specify mysql root password, either in .m2/settings.xml or in the pom.xml

        Should get something like:

        [10:41:04][MANTRUN-108]$ ../mvn-2.0.10
        [INFO] Scanning for projects...
        [INFO] ------------------------------------------------------------------------
        [INFO] Building MANTRUN-108
        [INFO] task-segment: [install]
        [INFO] ------------------------------------------------------------------------
        [INFO] [antrun:run

        {execution: validate}

        ]
        [INFO] Executing tasks

        validate:
        [INFO] Executed tasks
        [INFO] [antrun:run

        {execution: generate-resources}

        ]
        [INFO] Executing tasks

        generate-resources:
        [INFO] Executed tasks
        [INFO] [resources:resources]
        [WARNING] Using platform encoding (MacRoman actually) to copy filtered resources, i.e. build is platform dependent!
        [INFO] skip non existing resourceDirectory /Users/martinwest/workspaces/hattrick-ws-1.0.1/net.helixsys.tis/MANTRUN-108/src/main/resources
        [INFO] [compiler:compile]
        [INFO] Nothing to compile - all classes are up to date
        [INFO] [antrun:run

        {execution: generate-test-resources}

        ]
        [INFO] Executing tasks

        createdb:
        [execsql] Executing resource: /Users/martinwest/workspaces/hattrick-ws-1.0.1/net.helixsys.tis/MANTRUN-108/target/drop_tis_db.sql
        [execsql] Executing resource: /Users/martinwest/workspaces/hattrick-ws-1.0.1/net.helixsys.tis/MANTRUN-108/target/create_tis_db.sql

        ========= dies here ===================
        normally carries on with ....

        generate-test-resources:
        [INFO] Executed tasks
        [INFO] [resources:testResources]
        [INFO] Using default encoding to copy filtered resources.
        [INFO] [compiler:testCompile]
        [INFO] No sources to compile
        [INFO] [surefire:test]
        [INFO] No tests to run.
        [INFO] [jar:jar]
        [INFO] Building jar: /Users/martinwest/workspaces/hattrick-ws-1.0.1/net.helixsys.tis/MANTRUN-108/target/MANTRUN-108-test.jar
        [INFO] [install:install]
        [INFO] Installing /Users/martinwest/workspaces/hattrick-ws-1.0.1/net.helixsys.tis/MANTRUN-108/target/MANTRUN-108-test.jar to /var/maven2/MANTRUN-108/MANTRUN-108/test/MANTRUN-108-test.jar
        [INFO] ------------------------------------------------------------------------
        [INFO] BUILD SUCCESSFUL
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 4 seconds
        [INFO] Finished at: Thu Mar 05 10:51:11 GMT 2009
        [INFO] Final Memory: 10M/17M

        Martin West added a comment -

        also fails in this env

        Maven version: 2.0.10
        Java version: 1.6.0_10-beta
        OS name: "linux" version: "2.6.24-23-generic" arch: "amd64" Family: "unix"

        Brett Porter added a comment -

        the zip appears to be empty

        Martin West added a comment -

        DOH missed -r off, apologies.

        Brett Porter added a comment -

        confirmed (very bizarre - it looks like a stray System.exit, but not sure what behaviour changed yet)

        Brett Porter added a comment -

        affects 2.1.0-SNAPSHOT as well

        Brett Porter added a comment -

        it dies in the second transaction of the <sql /> call in the ant script, which takes considerably longer to run than the successful one from 2.1.0-M1/2.0.9 before failing

        I ran with -verbose:gc to see if it was an OOME, but that did not indicate any GC at the time

        Martin West added a comment -

        yes, I notice the time problem, is timing out on something?

        Brett Porter added a comment -

        my mistake - 2.0.10 upgraded the antrun plugin, I just missed that in the first place I looked.

        This is a regression between 1.2 and 1.3. If you set the version to either 1.1 or 1.2 in the POM you will avoid the problem under 2.0.10.

        Martin West added a comment -

        Thanks for the fast response.

        Michael Osipov added a comment -

        Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.


          People

          • Assignee:
            Unassigned
            Reporter:
            Martin West
          • Votes:
            3 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development