Mahout
  1. Mahout
  2. MAHOUT-893

Dependency Clash : Google Collections and Guava

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.5
    • Fix Version/s: 0.6
    • Component/s: collections
    • Labels:
    • Environment:

      windows

      Description

      I tried to run the Recommender example in Mahout in Action Book.

      DataModel model = new FileDataModel(new File("intro.csv"));
      UserSimilarity similarity = new PearsonCorrelationSimilarity(model);

      The dependencies from google collections and guava are clashing while execution. Its picking some wrong class like Preconditions and few others which is giving error on runtime. I fixed that by excluding google-collections. The patch is attached which helped me fix this problem.

      1. MAHOUT-893
        0.5 kB
        Paritosh Ranjan

        Activity

        Hudson added a comment -

        Integrated in Mahout-Quality #1195 (See https://builds.apache.org/job/Mahout-Quality/1195/)
        MAHOUT-893 exclude watchmaker's dependency on Collections

        srowen : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1205498
        Files :

        • /mahout/trunk/pom.xml
        Paritosh Ranjan added a comment -

        mahout-math needs guava9 and watchmaker is dependent on google collections, which looks like the problem to me. However, I can not completely deny that something I am including is leading to this. But, in certain cases, it can happen.

        Sean Owen added a comment -

        Hmm, I can't reproduce this. The tests don't fail, for example. Are you sure it's not due to something else you're including? Or I could believe it's just including a different subset of modules in a different order could trip over some latent clash here. It should do no harm to exclude its old version of collections, so can add this. Will test first.


          People

          • Assignee:
            Sean Owen
            Reporter:
            Paritosh Ranjan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development