Mahout
  1. Mahout
  2. MAHOUT-750

IndexOutOfBoundsException within sort method of OnlineSummarizer

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.5
    • Fix Version/s: 0.6
    • Component/s: Math
    • Labels:
      None

      Description

      When the total number of samples added to OnlineSummarizer is less than 100 , then sort() will thrown this :

      private void sort() {
      if (!sorted && starter != null)

      { starter.sortFromTo(0, 99); sorted = true; }

      }

      And I think it should be
      private void sort() {
      if (!sorted && starter != null)

      { starter.sortFromTo(0, Math.min(starter.size() - 1, 99)); sorted = true; }

      }

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        5h 5m 1 Sean Owen 30/Jun/11 08:45
        Resolved Resolved Closed Closed
        224d 6h 15m 1 Sean Owen 09/Feb/12 14:00
        Sean Owen made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Sean Owen made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Sean Owen added a comment -

        Duplicate of MAHOUT-692

        Sean Owen made changes -
        Field Original Value New Value
        Affects Version/s 0.6 [ 12316364 ]
        Assignee Sean Owen [ srowen ]
        Affects Version/s 0.4 [ 12314396 ]
        Priority Blocker [ 1 ] Major [ 3 ]
        Sean Owen added a comment -

        This "patch" is not against HEAD, as it is already fixed in HEAD. That's the good news but I'd advise you to work off HEAD if you're developing.

        XiaoboGu created issue -

          People

          • Assignee:
            Sean Owen
            Reporter:
            XiaoboGu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development