Mahout
  1. Mahout
  2. MAHOUT-729

Refactoring: Use Maps.newHashMap() and Lists.newArrayList() from Guava globally

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.6
    • Component/s: None
    • Labels:
      None

      Description

      I put on my refactoring hat today and started to replace all calls to "new HashMap" with Maps.newHashMap() as well as all calls to "new ArrayList" with Lists.newArrayList() from Guava. This should make the code much more readable as the generic type of a variable needs to be written only once per line. I also refactored some minor things I encountered along the way.

      1. MAHOUT-729.patch
        426 kB
        Sebastian Schelter

        Activity

          People

          • Assignee:
            Sebastian Schelter
            Reporter:
            Sebastian Schelter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development