Mahout
  1. Mahout
  2. MAHOUT-727

Does bin/mahout work for binary distro?

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.5
    • Fix Version/s: 0.6
    • Component/s: build
    • Labels:
      None

      Description

      Mark reports that bin/mahout doesn't work out of the box from the binary distribution.

      11/06/08 21:17:00 INFO mapred.JobClient: Task Id : attempt_201106061352_0066_r_000001_1, Status : FAILED
      Error: java.lang.ClassNotFoundException: org.apache.lucene.analysis.TokenStream

      This suggests the script isn't finding the job file, and indeed it is not in the same place in the binary distro as in the source tree. I am guessing this is the issue.

        Activity

        Alex Ott added a comment -

        Does will it work if you'll put -job.jar first in CLASSPATH? This maybe the same as I reported on dev mailing list...

        Sean Owen added a comment -

        Pretty sure I spotted and fixed the script issue here.

        Hudson added a comment -

        Integrated in Mahout-Quality #957 (See https://builds.apache.org/job/Mahout-Quality/957/)
        MAHOUT-727 fix location of examples job jar file for distribution

        srowen : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1150124
        Files :

        • /mahout/trunk/bin/mahout
        Choon-Siang Lai added a comment - - edited

        erm... seen this error after updating my working copy, apparently #1150124 introduced some change that returns error message as follows:

        $ bin/mahout fkmeans --input sensei/image-tag.mvc --output sensei/clusters --clusters sensei/clusters/clusters-0 --clustering --overwrite --emitMostLikely false --numClusters 50 --maxIter 10 --m 5
        Running on hadoop, using HADOOP_HOME=/home/jeffrey04/Applications/hadoop
        HADOOP_CONF_DIR=/home/jeffrey04/Applications/hadoop/conf
        ERROR: Could not find mahout-examples-*.job in /home/jeffrey04/Applications/mahout or /home/jeffrey04/Applications/mahout/examples/target, please run 'mvn install' to create the .job file

        However, the script works again after reverting this line

            for f in "$MAHOUT_HOME/examples/target/mahout-examples-*-job.jar" "$MAHOUT_HOME/mahout-examples-*-job.jar" ; do
        

        back to this (taken from 0.5-release)

            for f in $MAHOUT_HOME/examples/target/mahout-examples-*-job.jar; do
        

        should I start a new ticket, sorry if I hijacked this bug report?

        Operating Environment

        $ cat /etc/*-release
        DISTRIB_ID=Ubuntu
        DISTRIB_RELEASE=11.04
        DISTRIB_CODENAME=natty
        DISTRIB_DESCRIPTION="Ubuntu 11.04"
        $ uname -a
        Linux sensei 2.6.38-10-generic-pae #46-Ubuntu SMP Tue Jun 28 16:54:49 UTC 2011 i686 i686 i386 GNU/Linux

        Sean Owen added a comment -

        The problem is that the binary distro doesn't work with the old line.

        Does it work to un-quote both of those paths?
        How about making it two for-loops, one for the first pattern and one for the second?

        Choon-Siang Lai added a comment -

        Unquoting both seems to fix the problem

        Sean Owen added a comment -

        Great, I'll fix that now.

        Hudson added a comment -

        Integrated in Mahout-Quality #963 (See https://builds.apache.org/job/Mahout-Quality/963/)
        MAHOUT-727 fix typo in script with quoting paths in for syntax

        srowen : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1151093
        Files :

        • /mahout/trunk/bin/mahout

          People

          • Assignee:
            Sean Owen
            Reporter:
            Sean Owen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development