Mahout
  1. Mahout
  2. MAHOUT-68

addPoint, computeCentroid can use vector operators to do the respective task

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Clustering
    • Labels:
      None
    1. MAHOUT-68.patch
      2 kB
      Pallavi Palleti

      Issue Links

        Activity

        Pallavi Palleti created issue -
        Pallavi Palleti added a comment -

        used vector operations like plus,divide methods so that it works independent of whether it is sparse or dense vector.

        Pallavi Palleti made changes -
        Field Original Value New Value
        Attachment MAHOUT-68.patch [ 12385609 ]
        Isabel Drost-Fromm added a comment -

        Could you please also add a unit test that shows, that the current implementation is broken but your version works?

        Pallavi Palleti added a comment -

        In this way, we can hide the implementation and can optimize the code at vector level.

        Pallavi Palleti made changes -
        Summary addPoint, computeCentroid does not work for SparseVectors addPoint, computeCentroid can be represented with Vector operations
        Issue Type Bug [ 1 ] Improvement [ 4 ]
        Pallavi Palleti made changes -
        Summary addPoint, computeCentroid can be represented with Vector operations addPoint, computeCentroid can use vector operators to do the respective task
        Pallavi Palleti added a comment - - edited

        All this came because of my confusion in understanding the cardinality in Sparse Vector. So, this is not a bug and so existing unit tests hold even after the changes. My apologies for raising it as a bug.

        Grant Ingersoll added a comment -

        Per Pallavi's last comment.

        Grant Ingersoll made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Invalid [ 6 ]
        Pallavi Palleti made changes -
        Link This issue is cloned as MAHOUT-73 [ MAHOUT-73 ]
        Grant Ingersoll made changes -
        Workflow jira [ 12434922 ] no-reopen-closed, patch-avail [ 12444699 ]
        Sean Owen made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Pallavi Palleti
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development