Mahout
  1. Mahout
  2. MAHOUT-674

Let the TrainLogistic class could print the category feature weight probably

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.4, 0.5
    • Fix Version/s: 0.5
    • Component/s: Examples
    • Labels:
    • Environment:

      Mac OS X 10.6.7

      Description

      In the example of trainlogistic, if we add a category feature. It will throw a NullPointerException while printing out the model.

      The root cause is for category feature, the code try to use the feature name as the predictor rather than feature=value as the predictor while get the weight from the trained LR model.

        Activity

        Stanley Xu created issue -
        Stanley Xu added a comment -

        A one line patch should fix this issue and help the users could try using category feature for simple LR training as an example.

        Stanley Xu made changes -
        Field Original Value New Value
        Attachment trainlogsiticexample.diff [ 12476595 ]
        Sean Owen added a comment -

        Looks like a pretty clear oversight – the value is definitely intended to be a map key and this patch makes it so. Committed.

        Sean Owen made changes -
        Assignee Sean Owen [ srowen ]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Hudson added a comment -

        Integrated in Mahout-Quality #760 (See https://hudson.apache.org/hudson/job/Mahout-Quality/760/)

        Sean Owen made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        10h 29m 1 Sean Owen 18/Apr/11 22:32
        Resolved Resolved Closed Closed
        32d 5h 46m 1 Sean Owen 21/May/11 04:18

          People

          • Assignee:
            Sean Owen
            Reporter:
            Stanley Xu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 5m
              5m
              Remaining:
              Remaining Estimate - 5m
              5m
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development