Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Won't Fix
    • Affects Version/s: 0.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Is there any plan to implement ID3 and C4.5 algorithms in Mahout? I am an undergrad student who's working on Mahout as part of my senior year project. I plan to implement decision tree learning as part of my project and was wondering if it is a good enough idea to incorporate it into the mainstream application.

      Regards.
      Meher Anand

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        208d 20h 7m 1 Sean Owen 26/Sep/10 10:51
        Resolved Resolved Closed Closed
        236d 17h 35m 1 Sean Owen 21/May/11 04:27
        Anuroopa George added a comment - - edited

        Hi All,
        Can i start working on the implementation of ID3 and C4.5 algorithms?Anyone started working on it.?If not please do reply.
        Thanks

        Sean Owen made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Sean Owen made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Sean Owen added a comment -

        Only marking this "WontFix" since there is no apparent momentum in a long time to work on it. In principle of course it's open for anyone to run with this later.

        Deneche A. Hakim added a comment -

        There is already an implementation of Random Decision Forests where you can plug your own Tree building Algorithm. If you want to add ID3 or C4.5 to Mahout I will help you understand what parts of the code you should implement.

        Forest Tan added a comment -

        You can refer to this article from Google: http://www.bayardo.org/ps/vldb2009.pdf
        It is about both decision tree and regression tree learning.

        I think the priority of decision tree should be high since it is very common-used.

        Meher Anand created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Meher Anand
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development