Mahout
  1. Mahout
  2. MAHOUT-172

When running on a Hadoop cluster LDA fails with Caused by: java.io.IOException: Cannot open filename /user/*/output/state-*/_logs

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.1
    • Fix Version/s: 0.2
    • Component/s: Clustering
    • Labels:
      None

      Description

      I tried running the reuters example of lda on a hadoop cluster today. Seems like the implementation tries to read all files in output/state-* which fails if in that directory "_logs" is found.

      1. lda.patch
        1 kB
        Isabel Drost-Fromm

        Activity

        Isabel Drost-Fromm added a comment -

        The patch extends the url pattern to not match everything in the output directory but only stuff that starts with part* - since the lda job seems to run fine for me.

        David Hall added a comment -

        Sorry, just noticed this issue!

        Looks good to me.

        – David

        Isabel Drost-Fromm added a comment -

        Committing on Monday.

        Isabel Drost-Fromm added a comment -

        fixed in revision 814495


          People

          • Assignee:
            Isabel Drost-Fromm
            Reporter:
            Isabel Drost-Fromm
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development