Uploaded image for project: 'Apache MADlib'
  1. Apache MADlib
  2. MADLIB-1093

Update build from source wiki section with cmake version

    XMLWordPrintableJSON

Details

    • Documentation
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • None
    • v1.12
    • Documentation
    • None

    Description

      When trying to build on CentOS 6 and using the ancient version of cmake from yum, I encounter the following failure from cmake.

      We should update the wiki page to reflect the minimum version (or the version used in CI) to prevent others from having this issue.

      [gpadmin@gpdb-sandbox build]$ cmake ..
      -- Could NOT find Boost
      -- No sufficiently recent version (>= 1.47) of Boost was found. Will download.
      -- Found PythonInterp: /usr/local/greenplum-db/ext/python/bin/python (found version "2.6.2")
      -- Could NOT find PostgreSQL (missing:  POSTGRESQL_EXECUTABLE)
      -- Found Greenplum: /usr/local/greenplum-db-4.3.12.0/bin/postgres
      -- Found Greenplum_4_3ORCA: /usr/local/greenplum-db-4.3.12.0/bin/postgres
      >> Adding Greenplum 4.3ORCA (x86_64) to target list...
      -- Could NOT find HAWQ (missing:  HAWQ_EXECUTABLE)
      Segmentation fault (core dumped)
      

      Attachments

        Activity

          People

            espino Ed Espino
            kdunn926 Kyle R Dunn
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: