Uploaded image for project: 'Lucy'
  1. Lucy
  2. LUCY-299

Using Blob field type stops search working on other fields

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Not A Bug
    • Affects Version/s: 0.4.4
    • Fix Version/s: None
    • Component/s: Core
    • Environment:

      Ubuntu 15.10

      Description

      Running into an apparent issue using BlobType_new to create FieldType.

      Scenario:
      Creating a schema with two fields, "fullpath" and "title". Using EasyAnalyzer.
      Add a couple of entries to the index
      Issued a search against the index

      Problem: If for fullpath field I use BlobType_new for FieldType, no search match is found. However, if I use either FullTextType_new or StringType_new for the schema FieldType of fullpath, it works fine.

      If I do not add fullpath at all, not to schema nor of course with Doc_Store - i.e. just have a single field of title - my scenario works fine (get a search hit).

      If I add fullpath to the schema, but not to the doc entries (via Doc_Store), it works fine (get a search hit).

      It makes no difference (still get no match) if add fullpath before or after title.

      It makes no difference (still get no match) whether I pass true or false as parm to BlobType_new.

      In all cases, FieldType for title is fulltext; and it is title that is generating the matches against the search query.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              dgbulk DGB
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: