Lucy
  1. Lucy
  2. LUCY-187

Adapt to GC changes in Perl 5.15

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.1.0 (incubating), 0.2.0 (incubating), 0.2.1 (incubating), 0.2.2 (incubating)
    • Fix Version/s: 0.3.0 (incubating)
    • Component/s: Perl bindings
    • Labels:
      None

      Description

      Perl 5.15 adds a new phase during global destruction which invokes
      DESTROY on unreferenced SVs. This is causing a tripwire exception
      when VTable's DESTROY method gets called (VTable_Destroy() should
      never be called). However, the fix is more involved than simply
      disabling the tripwire.

        Activity

        Marvin Humphrey added a comment -

        The first patch ("bind to correct destructors") is a precursor bugfix that
        changes the destructor bindings working accidentally to working as intended.

        The second patch ("Disable DESTROY...") addresses this issue.

        Peter Karman added a comment -

        0.2.3 not planned

        Marvin Humphrey added a comment -

        Clownfish used a similar model, so it had similar problems. Over the
        course of many commits, those problems have also been addressed – so
        now this issue can now be resolved.


          People

          • Assignee:
            Marvin Humphrey
            Reporter:
            Marvin Humphrey
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development