Uploaded image for project: 'Lucene.Net'
  1. Lucene.Net
  2. LUCENENET-624

Fix asserts that are failing on .NET Standard 2.0

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: Lucene.Net 4.8.0
    • Fix Version/s: None
    • Component/s: Lucene.Net Core
    • Labels:
    • Flags:
      Important

      Description

      There are a few asserts that fail on .NET Standard 2.0. They have been conditionally compiled out of the code due to the fact that on .NET Core 2.1 they cause the test runner to fatally crash, however these are a sign that something could be seriously wrong with the codecs (possibly causing index corruption).

      Here are the known failures:

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              nightowl888 Shad Storhaug

              Dates

              • Created:
                Updated:

                Time Tracking

                Estimated:
                Original Estimate - 12h
                12h
                Remaining:
                Remaining Estimate - 12h
                12h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Issue deployment